Power & Source of Big Ideas

Help needed: NanoPC-T4 with eDP-panel

Moderators: chensy, FATechsupport

Hi,
I am new to this forum, new to the NanoPC and also new to eDP-panels, although I have been using several similar boards (Panda, Radxa, Raspberry, Orange PI, Ordroid, SECO ...) over the last couple of years.

It was very easy and straight forward to re-build and install Android 8.1 - thanks to the clear and concise documentation provided.

The next task is to connect the NanoPC-T4 to a 15.5-inch LCD-panel (B156HAT01.0) with Backlight and Touchscreen, and I am not clear which files need to be adjusted to cater 'my' panel specifications.

Please help me to get started!

Thanks for your help!
Hi, I also have to connect the NanoPC-T4 to a 15.5 inch LCD panel and I do not know how to do it, thanks.

__________________________________________________________________________
ShowBox Tutuapp Mobdro
Once I figure it out, I'll let you know!
Did you succeed connecting the panel via eDP?
I have added a Newhaven Display 7.0" to my Nano PC T3 Plus and to do so, you need to modify the driver in 2 places.

In uboot, you need to add the settings for your display and unless you can use the automatic 1-wire detection from FriendlyArm, which I am trying to with little success as the code for the STM8 is not freely available, then you need to somehow ensure that your LCD is the default.

You then also have to modify the Kernel with the same settings. The uboot will pass in the LCD type via the command line so you can use this to select the correct display. Just be sure to use a unique LCD name.
raimo wrote:
Did you succeed connecting the panel via eDP?


Yes, I got it running with a 15.5 inch panel - will post some more info hopefully soon.
Sorry, for the delayed response!
Thanks for the reply, any detailled help is greatly appreciated!

I tried to follow the docs (https://usermanual.wiki/Document/Rockch ... 297770.pdf) from Rockship which involved modifying a dts-file for the kernel and enabling the panel with sys.hwc.device.extend=eDP. Which other files do I need to touch?
I am using and HDMI panel + my eDP panel (http://www.szdengyi.com/upload/web/lcds ... op_lcd.pdf). The eDP panel stays dark and the HDMI pannel gets stuck showing the kernel logo.
I was successful in connecting a 15.6 inch eDP panel (B156HAK02.0 with Backlight and USB-Touchscreen) to my NanoPC-T4, with both the panel and HDMI showing the same contents.

As FriendlyELEC sells also a 7-inch eDP for the NanoPC, I took this as my starting point (thank you v8dave for the hint).

Essentially I changed 2 files:
a) kernel/drivers/gpu/drm/panel/panel-friendlyelec.c where I included my panel incl. the timings and
b) u-boot/board/rockchip/rk33xx/rk33xx.c where I included the panel and 'hard-selected' it. (It seems the NanoPC is not able to extract the model, so I decided to 'hard-select it as I don't have/need any other panel)

There was some hassle to get it running due to the fact that the timings and EDID-data in the datasheet were wrong. After obtaining the right timing-values from the factory everything is working smoothly.
As mentioned the Touch-Screen is connected via USB, and surprisingly it was running without any modification required.

There was no modification of a dts-file for the kernel and enabling the panel with sys.hwc.device.extend=eDP.

You write the LCD-panel stays dark - pls check your cable (I had a similar issue some time ago using a different SBC)

You can download the datasheet and 2 files I mentioned (please ignore other changes - mainly commented 'print-commands', and I2C-Touchscreen related) from https://www.dropbox.com/s/8yu2ufef8lp3t ... l.zip?dl=0
Dear Tiemichael,

Thanks a lot for your help and the files! So, even if the settings are wrong for the connected panel the backlight should always power on? I ordered a new cable now to check whether the old one is causing the issue. I will keep you updated!

Best regars,
Raimo
The backlight is controlled by a couple of signals controlled by the CPU. So if this configuration is wrong the Backlight would be not working..
My setup is based on a working setup (done by FriendlyELEC) with also includes a working setup for Backlight - so there is a high chance that the Backlight configuration is working also for other panels.

In my case the Backlight is ON the moment I switch ON the NanoPC.

Maybe you can have a look at the Backlight-signals using an Oscilloscope ...

Who is online

In total there are 6 users online :: 0 registered, 0 hidden and 6 guests (based on users active over the past 5 minutes)
Most users ever online was 2865 on Sun Nov 10, 2019 5:27 am

Users browsing this forum: No registered users and 6 guests