In the interest of TLDR I will make this as short as possible.

I decided to make my own version of debian for the Nanopi M4, I have compiled all of the .imgs

I originally couldn't get the device to be detected with the emmc conncted to the board.

I emailed both rock-chip & friendlyarm. I didn't get a reply from rock-chip, but did get a reply from friendlyarm. They firstly told me about deleting the first part of the emmc, using this command dd if=/dev/zero of=/dev/mmcblkX bs=10M count=1.

This allowed be to get the board to be detected when the emmc was connected. Only now I get errors stating "loading loader failed" obviously this was when uploading the bootloader img. But the same error happens with every part of the img upload process. I have tried this on both linux and windows with the same results. I also tried remaking the imgs from scratch to see if it was a problem with those, again no luck.

I emailed friendlyarm back and, well whilst they did respond there appears to be some confusion on their part. Stating I need to use that command on linux, which I obviously did. Anyway I emailed back trying to clear this up and haven't gotten any further. In fact I am now being ignored.

So does anyone have any idea if I am barking up the wrong tree with trying this? I know the M4 doesn't have the recovery mode button but since the device goes in to maskrom mode when connected I wouldn't have thought this be a problem?

Another step I tried was to edit the appropriate files for the EFlasher tool to allow me to upload a different operating system, this didn't work either.

I would be so grateful if anyone can offer an insight in to this as it would be nice to be able to make and share these img files for people that are interested in having a bit more diversity in the options they have for their M4 boards.