Power & Source of Big Ideas

xhci-hcd USB3 errors

Moderators: chensy, FATechsupport

Hi,
I really love the M4 I bought recently. Thank you for an amazing machine.
However, I am experiencing repeated errors while using the last version of the Ubuntu distro you provided:

Code: Select all

[   17.045101] xhci-hcd xhci-hcd.11.auto: ERROR Transfer event for disabled endpoint or incorrect stream ring
[   17.045972] xhci-hcd xhci-hcd.11.auto: @000000007b7617e0 00000000 00000000 1b000000 03038000
[   17.050824] xhci-hcd xhci-hcd.11.auto: ERROR Transfer event for disabled endpoint or incorrect stream ring
[   17.051691] xhci-hcd xhci-hcd.11.auto: @000000007b761900 00000000 00000000 1b000000 03038000
[ 1223.308545] xhci-hcd xhci-hcd.11.auto: ERROR Transfer event for disabled endpoint or incorrect stream ring
[ 1223.309441] xhci-hcd xhci-hcd.11.auto: @000000007b7613d0 00000000 00000000 1b000000 03038000
[ 1272.102634] xhci-hcd xhci-hcd.11.auto: ERROR Transfer event for disabled endpoint or incorrect stream ring
[ 1272.103531] xhci-hcd xhci-hcd.11.auto: @000000007b761540 00000000 00000000 1b000000 03038001
[ 1975.816800] xhci-hcd xhci-hcd.11.auto: ERROR Transfer event for disabled endpoint or incorrect stream ring
[ 1975.817694] xhci-hcd xhci-hcd.11.auto: @000000007b761e70 00000000 00000000 1b000000 03038001
[ 2047.325361] xhci-hcd xhci-hcd.11.auto: ERROR Transfer event for disabled endpoint or incorrect stream ring

Please help me figure out the issue.
Here is the output of

Code: Select all

lsusb -t
-- I have three self-powered HDD (4TB, 4TB, 6TB) attached using USB3 compliant docks on the NM4 which I use as a local server:

Code: Select all

/:  Bus 06.Port 1: Dev 1, Class=root_hub, Driver=ohci-platform/1p, 12M
/:  Bus 05.Port 1: Dev 1, Class=root_hub, Driver=ehci-platform/1p, 480M
/:  Bus 04.Port 1: Dev 1, Class=root_hub, Driver=xhci-hcd/1p, 5000M
    |__ Port 1: Dev 2, If 0, Class=Hub, Driver=hub/4p, 5000M
        |__ Port 1: Dev 3, If 0, Class=Mass Storage, Driver=uas, 5000M
        |__ Port 3: Dev 4, If 0, Class=Mass Storage, Driver=uas, 5000M
        |__ Port 4: Dev 5, If 0, Class=Mass Storage, Driver=uas, 5000M
/:  Bus 03.Port 1: Dev 1, Class=root_hub, Driver=xhci-hcd/1p, 480M
    |__ Port 1: Dev 2, If 0, Class=Hub, Driver=hub/4p, 480M
/:  Bus 02.Port 1: Dev 1, Class=root_hub, Driver=ohci-platform/1p, 12M
/:  Bus 01.Port 1: Dev 1, Class=root_hub, Driver=ehci-platform/1p, 480M
how about to attach your HDDs to the USB2 port?
I also found some issue on USB3...

Who is online

In total there are 3 users online :: 0 registered, 0 hidden and 3 guests (based on users active over the past 5 minutes)
Most users ever online was 5185 on Wed Jan 22, 2020 1:44 pm

Users browsing this forum: No registered users and 3 guests