Power & Source of Big Ideas

CSI(ov13850) with the NanoPi T4 does not work on ubunty

Moderators: chensy, FATechsupport

Hi there!

I can't get a picture from the CSI camera(ov 13850) on NanoPi - T4, i use ubunty :cry: .

- First i read manual (http://wiki.friendlyarm.com/wiki/index.php/NanoPC-T4)
"FriendlyELEC provides a test script "gst-camera.sh" to test a camera's functions" - I couldn't find this file :?:
- Next, I tried running through gst-launch-1.0, but No dev/video* on ubunty.
- Tried to read the data from I2C.

What am I doing wrong? I really appreciate any help you can provide.
did you use latest version(from 2018/12/19) of Friendly Desktop(ubuntu 18.04)?

test script "gst-camera.sh" to test a camera's functions" - I couldn't find this file

it's

Code: Select all

/usr/local/bin/gst-camera.sh
I updated my Friendly Desktop to Ubuntu 18.04.1 LTS!
Yhy, Appeared file gst-camera.sh (/usr/local/bin/gst-camera.sh).

But there is no dev/video* ( There is dev/iio:video0 - That's what i need or not??
I try

Code: Select all

gst-launch-1.0 rkisp device=/dev/iio:video0 io-mode=4 ! video/x-raw,format=NV12,width=640,height=480 ! rkximgesink

And get log

Code: Select all

XCAM INFO device_manager.cpp:90: open /usr/lib/libcam_ia.so successed
XCAM INFO device_manager.cpp:96: open /usr/lib/libcam_engine_cifisp.so successed
XCAM INFO device_manager.cpp:106: dlsym rkisp_start success
WARNING: erroneous pipeline: no element "rkximgesink"
:(

Code: Select all

no element "rkximgesink"
it's just a FriendlyArm display utility for X11, which for some reason missed.

looks like you have broken Linux installation on you board - can you check with clear install of rk3399-sd-friendlydesktop-bionic-4.4-arm64-20181219.img.zip (SD card version only to make it easy to install)

Who is online

In total there are 9 users online :: 0 registered, 0 hidden and 9 guests (based on users active over the past 5 minutes)
Most users ever online was 5185 on Wed Jan 22, 2020 1:44 pm

Users browsing this forum: No registered users and 9 guests