Power & Source of Big Ideas

Installing ubuntu desktop on M4

Moderators: chensy, FATechsupport

Dear All, I really would like to have Ubuntu-desktop on the M4 unfortunately what ever I do I get stuck.
I managed to install:
rk3399-eflasher-friendlydesktop-bionic-4.4-arm64-20181219.img
and flash it to the eMMC.
I then reboot and login as root to the eMMC terminal.
sudo apt-get update
sudo apt-get upgrade

then I understand it is better to
sudo apt-get install tasksel

and then if I launch it and try to install anything I get:
tasksel: apt-get failed (100)
almost immediately..
I can't find anything usefull in /var/log and /var/log/apt

Anyway I try to manually start the install using sudo apt-get install ubuntu-desktop
and sudo apt-get install ubuntu-desktop^

and then I get:

Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
ubuntu-desktop : Depends: gvfs-bin
Recommends: bluez-cups but it is not going to be installed
Recommends: cups
Recommends: cups-bsd
Recommends: cups-client
Recommends: cups-filters but it is not going to be installed
Recommends: hplip but it is not going to be installed
Recommends: printer-driver-foo2zjs but it is not going to be installed
Recommends: printer-driver-m2300w but it is not going to be installed
Recommends: printer-driver-pxljr but it is not going to be installed
Recommends: printer-driver-splix but it is not going to be installed
E: Unable to correct problems, you have held broken packages.


I tried several things like:
dpkg --configure -a

but nothing seems to work... Any help appreciated...
Related to that first post, I am actually looking for the full Ubuntu,gnome, gdm3 including preference panel and localistion, etc..
I.e I am trying to install the Swiss-french keyboard on it and although I managed to install it ( visible on the top right of the menu bar with both english and Swiss-french option selectable... the terminals do no change keyboard nor chrome nor code-oss.
basically I feel like the current friendlyelec doesn't have the maturity and configuration possibilities of a stable gnome desktop.
Also trying to install a VNC (which is not enabled by default doesn't seem to work very well either...). Finally my nanopi m4 crashed twice yesterday (black screen and completely turned itself off). I am still not sure if it is possibly a hardware related crash.
theshade, Please read my thread - viewtopic.php?f=62&t=2036
There I tried to describe in as much detail as possible the procedure for obtaining a good working space.

Who is online

In total there are 2 users online :: 0 registered, 0 hidden and 2 guests (based on users active over the past 5 minutes)
Most users ever online was 5185 on Wed Jan 22, 2020 1:44 pm

Users browsing this forum: No registered users and 2 guests