Power & Source of Big Ideas

NanoPi M4 microphone input

Moderators: chensy, FATechsupport

Can anyone confirm if the analog microphone input is functional on the NanoPi M4? I mean with plain ALSA and the latest kernel from either FriendlyElec, or Armbian, or anything else. Can you go into alsamixer and turn it on and does it actually work? I need to know this before I buy...

I don't think any os uses alsamixer.
It should all be pulseaudio instead.

I've tried the 3.5mm plug with a stereo microphone in Armbian Bionic and it didn't work there.
With the Lubuntu's you could have more luck.

I've tried usb audio adapters and these all work.
Thanks NicoD. I watched your video review of the M4 yesterday; it was super helpful!

If mic recording works through pulseaudio, that would be fine; I'm just more familiar with plain ALSA.

Looking at the schematic, there are actually two microphone inputs connected to the codec chip. The 3.5mm plug is a TRRRS (five conductors) which has stereo out as well as mono mic in. I'm not sure if that is a standard "pinout", but even if it is, I would guess that a plug-in mic is unlikely to work unless it is a set of stereo earbuds with a mic in the cord, like a cellphone accessory. From the wiring it looks like it may be compatible with a TRRS (four conductor) plug as well.

There is another microphone input next to the 3.5mm jack, which is just a pair of holes at standard 0.1" spacing, so you have to solder a connector or wire the mic directly to that one.

I can see that all of these are connected to the codec in a reasonable way. I just worry that the supplied drivers may not have been written to configure the codec registers correctly for recording. It's the kind of thing which often gets missed because few people use it.

If you have the basic ALSA utilities on the board, could you dump the output of "arecord -l"? That would tell us if the software believes that it has a microphone input. If it doesn't list any capture devices, the mic definitely won't work; if it lists some, it might work :)
mark03 wrote:
There is another microphone input next to the 3.5mm jack, which is just a pair of holes at standard 0.1" spacing, so you have to solder a connector or wire the mic directly to that one.

I think they were planning to add a mic there. There's one on the T3+, only works in the FriendlyElec images.

What do you need it for? You could always use a cheap usb microphone like these.

I've got many usb audio adapters with audio out + in, they all work on it.
I've also got a presonus usb audiobox to record music. I also use it to record the sound of my video's. Works on all my sbc's without any installation.

I don't have my M4 here right now, when I've got time I'll check that out. PulseAudio does detect there's audio in and audio out on the board. But it's not working in Armbian. Guess not either in Lubuntu then.

Who is online

In total there are 9 users online :: 0 registered, 0 hidden and 9 guests (based on users active over the past 5 minutes)
Most users ever online was 5185 on Wed Jan 22, 2020 1:44 pm

Users browsing this forum: No registered users and 9 guests