Power & Source of Big Ideas

LXDE on NanoPi Duo

Moderators: chensy, FATechsupport


I just set up my new NanoPi Duo with the nanopi-duo_ubuntu-core-xenial_4.11.2_20170908.img. I connected to my router and I am able to ssh into just fine. I did the apt-get update, df -h, and set my options with npi-config. I would like to be able to VNC into it and use a desktop envrinment. I installed ldxe on it, but when I do startx - I get the following error:

root@NODE-NANOPIDUO:~# startx

X.Org X Server 1.18.4
Release Date: 2016-07-19
X Protocol Version 11, Revision 0
Build Operating System: Linux 4.4.0-83-generic armv7l Ubuntu
Current Operating System: Linux NODE-NANOPIDUO 4.11.2 #1 SMP Mon Jul 10 11:06:36 CST 2017 armv7l
Kernel command line: console=tty0,115200 earlyprintk root=/dev/mmcblk0p2 rootfstype=ext4 rw rootwait fsck.repair=yes panic=10 fbcon=map:0
Build Date: 17 July 2017 05:06:30PM
xorg-server 2:1.18.4-0ubuntu0.3 (For technical support please see http://www.ubuntu.com/support)
Current version of pixman: 0.33.6
Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.1.log", Time: Thu Sep 14 10:18:36 2017
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
gbm: failed to open any driver (search paths /usr/lib/arm-linux-gnueabihf/dri:${ORIGIN}/dri:/usr/lib/dri)
gbm: Last dlopen error: /usr/lib/dri/sun8i-de2_dri.so: cannot open shared object file: No such file or directory
failed to load driver: sun8i-de2
EGL_MESA_drm_image required.
xinit: connection to X server lost

waiting for X server to shut down (II) Server terminated successfully (0). Closing log file.

I also tried:

Agent pid 5766
** Message: main.vala:99: Session is LXDE
** Message: main.vala:100: DE is LXDE

(lxsession:5764): Gtk-WARNING **: cannot open display:

Are we not able to run a desktop environment on this version of Ubuntu?

Hi Frank,

maybe you need a Virtual-Framebuffer (because without GFX-Card you didnt got a Framebuffer where the XServer can start with) - thats what I think personally.

I googled a little around and did found this page:
Headless VNC-Server using xvfb

You could check if it would help you ;)
I did this and used remote desktop connection on Win10 and it worked. A bit slow, but works.
apt-get install xubuntu-desktop
apt-get install xrdp

Who is online

In total there are 5 users online :: 0 registered, 0 hidden and 5 guests (based on users active over the past 5 minutes)
Most users ever online was 5185 on Wed Jan 22, 2020 1:44 pm

Users browsing this forum: No registered users and 5 guests