Power & Source of Big Ideas

A64 and DVP camera CAM500A

Moderators: chensy, FATechsupport

What are the correct drivers to use the DVP-camera CAM500A with the NanoPI A64? The following modules were installed without knowing what they should do. What are the correct camera drivers and the device files?

Code: Select all

# lsmod
Module                  Size  Used by
actuator                1424  0
ov5640                 34002  0
vfe_v4l2              779480  0
vfe_io                 42679  2 vfe_v4l2,ov5640
videobuf2_dma_contig     9997  1 vfe_v4l2
videobuf2_core         31877  1 vfe_v4l2
videobuf2_memops        2691  1 videobuf2_dma_contig
8189es               1032333  0
# ls -latr /dev/vide*
ls: cannot access '/dev/vide*': No such file or directory


I have installed the cord already twice. It is straight and attached. How to install the camera module?

Jimsy
CAM500A is not compatible with NanoPi A64. Look for CAM500B. You can convert CAM500A to CAM500B with some soldering skills.
The jumper is now swapped from R6 to R5 as in https://www.friendlyarm.com/index.php?route=product/product&path=78&product_id=155. It did not help in installing. The device file did not appear by itself, I'm assuming it to be /dev/video0 if this is an automated filesystem. What are the major and minor numbers to install the file /dev/video0 to test?
Jimsy
As in
https://linuxtv.org/downloads/v4l-dvb-apis/uapi/v4l/dev-capture.html and
http://www.tldp.org/HOWTO/html_single/Webcam-HOWTO/#DEV-MANUAL
the device file can be installed like

Code: Select all

mknod video0 c 81 0

Still the following error, the device is not found:

Code: Select all

# streamer -c /dev/video0 -b 16 -o outfile.jpeg
files / video: JPEG (JFIF) / audio: none
v4l2: open /dev/video0: No such device or address
vid-open: failed: libv4l
no grabber device available

The jumpers are now double checked. This is CAM500B now if the instructions were correct. What is wrong here?
Jimsy
Short answer:
a) Your modules seem fine
b) Your OS Image must have the right configuration and that depends on which Image is in use.

Triple check your soldering, If you think they are 100% correct you have some options:
a) Try this: https://github.com/avafinger/nanopi-a64-kodi
This is already configured and will create /dev/video? , using it is another matter. It is a mainline kernel and CLI (no Desktop).

b) There is a lot of discussion about ov5640 on Armbian Forum that could help you understand how it should work.
I decided to upgrade instead because of the already made other configuration. This lead to the following problems.

The Linux version is now upgraded from Ubuntu 16 to 18 with 'do-release-upgrade'. It worked after increasing the FriendlyElec images /boot partition size and by restoring the root partition. The new kernel v4 is now compiled. The kernel is as a gz image, not inside the /boot/boot.img .

1. How to access UBoot prompt? How to turn on the UBoot verbose output? The bootlogo shows and nothing happens.
2. How to pack the kernel inside the img -file? Is the img always the first file and/or is it always the first file in the image? Is the img -file necessary with this UBoot configuration?

This is how I've tried the first v3.16 kernel when only the bootlogo appeared:
extract:

Code: Select all

abootimg -x boot.img

compress:

Code: Select all

abootimg --create boot.img -f bootimg.cfg -k zImage -r initrd.img


Is it possible to copy the mentioned images UBoot? How do I do this?

So far I'm able to use SSH and if necessary, the TV works with the HDMI connection (if the connection was on during boot).

Jimsy

Who is online

In total there is 1 user online :: 0 registered, 0 hidden and 1 guest (based on users active over the past 5 minutes)
Most users ever online was 2865 on Sun Nov 10, 2019 5:27 am

Users browsing this forum: No registered users and 1 guest