Page 1 of 1

NanoPi A64 shows Lifesigns with armbian image for pine64

Posted: Wed Apr 18, 2018 7:23 pm
by guidol
Someone did (succesfully) try to boot a arch-linux image for the pine64 on a NanoPi A64....

So I did try to boot the latest armbian nightly with mainline kernel for the pine64 on my NanoPi A64.

OK, the network interfaces (LAN RTL8211E and WiFi RTL8189ETV) and the soundcard arent available.
So I used a USB-network card :)

1GB memory is recognized.....

You could see the u-boot and dmesg-errors at
https://forum.armbian.com/topic/6987-a6 ... ment=53166

Maybe friendlyarm could spend some informations or driver sources (loadable modules for network)?

Re: NanoPi A64 shows Lifesigns with armbian image for bpi m64

Posted: Wed Sep 26, 2018 3:49 pm
by guidol
also the armbian image for the Banana Pi M64 do - somewhat - work at the NanoPi A64.

Also no ethernet/leds/soundcard and only one USB-Port (the lower one) - but with a USB-Hub you can connect
usb-ethernet
usb-soundcard

https://forum.armbian.com/topic/6987-a6 ... ment=62718

ARMBIAN 5.59 testing Debian GNU/Linux 9 (stretch) 4.14.70-sunxi64
Linux nanopi-a64 4.14.70-sunxi64 #274 SMP Wed Sep 19 12:09:30 CEST 2018 aarch64 GNU/Linux

Re: NanoPi A64 shows Lifesigns with armbian image for pine64

Posted: Mon Jan 14, 2019 6:39 am
by Hannes Worst
In the meanwhile, the latest Armbian build for the pine64 is declared 'stable'. And ir runs perfectly on my nanopiA64. Wifi is recognised and easy to configure. Almost everything works out of the box. Armbian-config is an amazing tool! :D

Re: NanoPi A64 shows Lifesigns with armbian image for pine64

Posted: Mon Jan 14, 2019 10:14 am
by guidol
Hannes Worst wrote:
In the meanwhile, the latest Armbian build for the pine64 is declared 'stable'. And ir runs perfectly on my nanopiA64. Wifi is recognised and easy to configure. Almost everything works out of the box.

Cool would be when ethernet (RTL8211E) would also be recognized, but with the pine64-image only wlan0 is seen by the system or a USB-ethernet-module.

While I was looking around in the armbian-build-system I did see the .DTB and a def-config file for the NanoPi A64.
I was thinking about a little bit of cheating the config of the pine64-board-config to use the NanoPi A64-defconfig
(maybe that would compile teh image with the .DTB of the NanoPI A64?)

Dont know if that would help anything (mostly the RTL8211E driver would be missing).

So I will have to find a source for the driver of the RTL8211E? - sounds to easy ;)

Re: NanoPi A64 shows Lifesigns with armbian image for pine64

Posted: Mon Jan 14, 2019 12:57 pm
by Hannes Worst
My expertise on this issue is very limited, but could it not also be a uboot problem? Something like this:http://u-boot.10912.n7.nabble.com/PATCH-1-1-net-phy-realtek-Add-support-for-RTL8211DN-and-RTL8211E-phy-modules-td159607.html?

Re: NanoPi A64 shows Lifesigns with armbian image for pine64

Posted: Mon Jan 14, 2019 5:41 pm
by guidol
Hannes Worst wrote:
Almost everything works out of the box.

In the meantime I did this experiment and edited the pin64-boardconfig inside the armbian-build-system for the NanoPi A64,
because the complete build-system did have a .dtb and defconfig-file for the NanoPi A64:
./build/cache/sources/u-boot/v2018.11/configs/nanopi_a64_defconfig

So - please - take a look at
https://forum.armbian.com/topic/9308-ex ... anopi-a64/

Maybe - with some other users & helping hands - we could get a better (unofficial) armbian-build for the NanoPi A64

NPi-A64-armbian.boot-logo.jpg
armbian on NanoPi A64
NPi-A64-armbian.boot-logo.jpg (67.65 KiB) Viewed 6568 times