Hi all,

I was trying to setup a NanoPi Neo Air for console access over bluetooth - to avoid the need to plug in all the time the cable, following the suggestions in this post.

Instead of using the script I have updated the config files directly as follows:

the /lib/systemd/system/bluetooth.service I have updated as follows:

Code: Select all

ExecStart=/usr/lib/bluetooth/bluetoothd -C
ExecStartPost=/usr/bin/sdptool add SP
ExecStartPost=/bin/hciconfig hci0 piscan

I have created the file /etc/systemd/system/rfcomm.service with the following content:

Code: Select all

Description=RFCOMM service

ExecStart=/usr/bin/rfcomm watch hci0 1 getty rfcomm0 115200 vt100 -a pi


I have activated the service with:

Code: Select all

sudo systemctl enable rfcomm
sudo systemctl restart rfcomm

After restating the board if I run systemctl I can see the services active:

Code: Select all

bluetooth.service                                                   loaded active running   Bluetooth service
rfcomm.service                                                      loaded active running   RFCOMM service

Now on my mac I go to bluetooth icon and I can see the device being advertised. But if I click on Connect after a short brief "Connected" moment the system moves to "Connection failed".

Has anybody tried to use the bluetooth serial as a console? Or does anybody have any ideas how I can find what the problem is? I've been trying in vain to find a log.