Power & Source of Big Ideas

Unable to connect SSH

Moderators: chensy, FATechsupport


I don't know if I post on right section. If not, I'm sorry.

I bought 3 NanoPi NEO. I have problem with all of them, as you can see in subject.

I downloaded official image Ubunto Xenial with kernel 4.11 burn on microSD (Kingston 16Gb class 10) with etcher ou USB creator from Linux Mint Cinamon, I put in the nanopi neo.

On my router I see IP of it. I can ping with somes loses packets, but I cannot connect with ssh. As "pi" or as "root".
ssh_dispatch_run_fatal: Connection to port 22: Operation timed out

I tried with Dietpi and ARMbian, same problem.


I don't know why, with many many many tries, I have one microsd who works. I can connect and do what I want.
But finally I need to know why I can't create a stable system from standard process.

Hope someone can help me
It sounds to me you have a fundamental problem if this is affecting multiple o/s

Perhaps have a think about:

1) power supplies ok?
2) sd cards ok?
3) device ping responses ok?
4) firewall rules / port path to devices ok?

A common error is to try to connect with SSH to the wrong device.

On the other hand, the starting of the system is very slow, and one have to be patient and wait enough before concluding it is not working.

Your USB power supply must also provide enough current: the use of a 5V/2A USB charger is recommended -- in my case, I have used the [high power] USB 3.0 port of my PC.

This is a procedure that worked for me -- using an Armbian 5.25 Debian distrib:

1) Put a valid system image on a microSD card and plug it in the NanoPi NEO's microSD reader.

2) Plug the NanoPi in thru a RJ45 cable to a local network running a DHCP server.

3) Get the current IP addresses list from the DHCP server.

4) Plug the NanoPi's power supply micro USB connector in.

5) Wait for several -- tens of -- seconds until the system gets ready and retreives an IP address from the DHCP server -- be patient.

6) Get the new IP addresses list from the DHCP server in order to check wether the NanoPi is connected and to get its IP address. Say the IP address is

7) Connect with SSH to the NanoPi: ssh or directly: ssh root@ if root is the administrator login.

The first time your system is connecting with SSH to the new IP address, it asks you for a confirmation to accept and save the corresponding security parameters.

8) Wait for the login prompt -- be patient. Then enter the administrator login. In my case this was root.

9) Wait for the password prompt -- be patient. Then enter the default administrator password. In my case this was 1234.

10) Enjoy...

Please try and tell us.

Thanks for yours answers, I found problem. I newer see it before.

NanoPi is incomptable with Switch Manageable Dlink DGS-1210-48. I don't know why.

I put it on router directly without pass trough the Dlink switch and It's work well!

I don't know why, because I don't have specials rules on switch, no VLAN etc.

What do you think about this?

Do you have successfully logged in or not via ssh?
Login via SSH
The NanoPi NEO doesn't have a video output interface. You can log into the board via SSH. In our test the IP address detected by our router was and we ran the following command to log into the NanoPi NEO:

$ ssh root@
The password is :fa.

Thanks, for your answer. As I said in previous post. I solve the problem, I can connect to Nanopi in SSH.

The problem is from switch and I don't know why.


Who is online

In total there are 10 users online :: 0 registered, 0 hidden and 10 guests (based on users active over the past 5 minutes)
Most users ever online was 5185 on Wed Jan 22, 2020 1:44 pm

Users browsing this forum: No registered users and 10 guests