Power & Source of Big Ideas

'Display Debian GUI on 2.8"LCD' does not work on M1, why?

Moderators: chensy, FATechsupport

Nanopi status LCD program works fine:

But 'Display Debian GUI on 2.8"LCD' does not work on my M1:

Likely because of the ioctl error logged, what does that mean, or how to prevent?

Code: Select all

Last login: Sat Nov 19 04:58:09 2016 from oc7888421160.fritz.box
root@NanoPi-M1:~# cd matrix/demo/nanopi-status/
root@NanoPi-M1:~/matrix/demo/nanopi-status# ./display-debian.sh /dev/fb-st7789s
-bash: ./display-debian.sh: Permission denied
root@NanoPi-M1:~/matrix/demo/nanopi-status# chmod 755 display-debian.sh
root@NanoPi-M1:~/matrix/demo/nanopi-status# ./display-debian.sh /dev/fb-st7789s
root@NanoPi-M1:~/matrix/demo/nanopi-status# dmesg | tail -14
[  323.054008] EXT4-fs (mmcblk0p2): last error at 1479486542: ext4_remount:4398: inode 744
[  338.033580] fbtft_device: module is from the staging directory, the quality is unknown, you have been warned.
[  338.045341] fbtft_device:  SPI devices registered:
[  338.050705] fbtft_device:      spidev spi0.0 33000kHz 8 bits mode=0x00
[  338.057947] fbtft_device:  'fb' Platform devices registered:
[  338.477419] graphics fb8: fb_st7789s frame buffer, 240x320, 150 KiB video memory, 16 KiB DMA buffer memory, fps=30, spi0.2 at 25 MHz
[  338.490717] fbtft_device:  GPIOS used by 'matrix-st7789s':
[  338.496804] fbtft_device:    'dc' = GPIO1
[  338.501285] fbtft_device:    'reset' = GPIO203
[  338.506211] fbtft_device:    'cs' = GPIO67
[  338.510766] fbtft_device:  SPI devices registered:
[  338.516081] fbtft_device:      spidev spi0.0 33000kHz 8 bits mode=0x00
[  338.523338] fbtft_device:      fb_st7789s spi0.2 25000kHz 8 bits mode=0x00
[  339.109446] [DISP] disp_ioctl,line:1584:para err in disp_ioctl, cmd = 0x0,screen id = 65536

Do you need to fix the Permission denied, near the beginning?
davef wrote:
Do you need to fix the Permission denied, near the beginning?

I did that in 2nd line, and execution in 3rd line was without permission denied, but did not work (black screen) ...

Oops :(
Now just debian system supports the matrix hardware,what system did you use? You can clone the matrix code on the board,and execute the following commands on the board :
$ apt-get update && apt-get install git
$ git clone https://github.com/friendlyarm/matrix.git

Compile and install Matrix:
$cd matrix/demo/nanopi-status
$./run.sh /dev/fb-st7789s

Boot your ARM board with Debian and and launch the Debian GUI by running the following commands:
$ cd matrix/demo/nanopi-status/
$ ./display-debian.sh /dev/fb-st7789s

I have exactly the same problem with the M1. (I verified this with 2 separate boards and displays)
I've tried this with an older debian image and the newest one and I get the same result as you every time.
My display works perfectly fine with the status script but the display-debian script doesn't work at all (very disappointing since this is what I purchased the board for :evil: ).

The display lights up white for a second when you start the script and the switches to black and does nothing.
I followed the steps outlined on the wiki page to start the script
$ cd matrix/demo/nanopi-status/
$ ./display-debian.sh /dev/fb-st7789s

Who is online

In total there are 18 users online :: 0 registered, 0 hidden and 18 guests (based on users active over the past 5 minutes)
Most users ever online was 5185 on Wed Jan 22, 2020 1:44 pm

Users browsing this forum: No registered users and 18 guests