Page 1 of 1

NanoPi-NEO I/O specifications discrepancy

Posted: Wed Aug 24, 2016 6:58 am
by Christos
Hi,

As we see on the NanoPi-NEO images and pin definition brochures
here
-> http://www.friendlyarm.com/image/catalo ... _en_04.jpg
and here
-> http://www.friendlyarm.com/image/catalo ... _en_03.jpg

there is mention of separate LineIn/Mic and I2S0 headers and pins exposed.

Yet, in the wiki NanoPi-NEO and in the schematics, the I2S0 pins are not exposed and a pinheader is missing.

Can you please let me know if the NEO has (in its final production form) the I2S0 lines exposed?

Or if not, then just change the product shown images to match the delivered functionality.

Thanks.

Re: NanoPi-NEO I/O specifications discrepancy

Posted: Wed Aug 24, 2016 5:08 pm
by HermannSW
Interesting, seems to be a new version of the board.
I do not have the 5 (new) audio pins (between single row 12 pin and Debug UART.
My board looks like the one described in Neo Wiki:
http://wiki.friendlyarm.com/wiki/index.php/NanoPi_NEO#Layout

Audio pins are available in 12 pin single row (8-12), scroll down the Wiki page a bit.
And save the Wiki page as it is now, just in case they update it to new board
(they should show both versions in the Wiki then, but who knows)

Hermann.

Re: NanoPi-NEO I/O specifications discrepancy

Posted: Thu Aug 25, 2016 9:07 am
by Christos
So FriendlyArm has to reply if there will be a new version exposing the I2S0 pins and getting audio pins too on a separate header (adding the appropriate schematics in the wiki).

Is this a new version that will be delivered with new NEO purchases?

Re: NanoPi-NEO I/O specifications discrepancy

Posted: Tue Sep 06, 2016 4:38 pm
by raiatea
According to the schematics :
In ver 1606:
- I2S is not connected,
- analog audio LINEOUT and MICIN1 are connected to CON2 pins 8-11

In ver 1.1, 1607:
- I2S is connected to CON2 pins 8-11
- analog LINEOUT and MICIN1 are on connector 'Audio' pins 1-3,5

In both versions, H3 pins LINEIN and MICIN2 are not connected.

I have ordered a board on 15 Aug, received the 3 sept, it is ver 1.1 1607. There is the 'Audio' connector.

Re: NanoPi-NEO I/O specifications discrepancy

Posted: Wed Sep 07, 2016 7:53 am
by HermannSW
Interesting, this photo of one of my Neos is from an older posting and shows "1606" above FRIENDLYARM at bottom right of the red rectangle (with Debug UART labels):
Image

This is screenshot from current Nanopi Neo product page, with new 5pin Audio connector and FRIENDLYARM printed at another place:
Image

Hermann.

Re: NanoPi-NEO I/O specifications discrepancy

Posted: Thu Sep 08, 2016 2:55 am
by FATechsupport
Hi all

Our current NEO is V1.1. Please check our wiki which lists the differences between the current one and the old one.

Re: NanoPi-NEO I/O specifications discrepancy

Posted: Thu Sep 08, 2016 7:42 am
by HermannSW
It is good that you show the differences in table USB/Audio/IR Pin Description in Nanopi Neo Wiki:
http://wiki.friendlyarm.com/wiki/index.php/NanoPi_NEO

There is the Debug Port´╝łUART0) section as well, but for Neo V1.1 the section describing the 5 new Audio pins is missing (currently).

Hermann.