Power & Source of Big Ideas

pps-gpio support in Friendlyarm 4.4

Moderators: chensy, FATechsupport

Has anyone had any luck pps-gpio work in friendlyarm 4.x yet? I'm trying to use a Fire 3 I've got my gps talking to gpsd and ntpd, but I can't figure out how to get PPS into the mix.

I tried a different route using rpi_gpio_ntp but it couldn't detect any of the gpio pins I tried. Then I found a post here about using the Nanopi M3 without gpio drivers, but when I try:

Code: Select all

echo 92 > /sys/class/gpio/export

I don't end up with any gpio in /dev/.

Just trying to get pps working by any means. Kernel pps would be best but I'll take what I can get. Am I missing something?
I have had no problem getting rpi to work on my Nano PI Neo via a GPIO. I selected GPIO 2, which is available. Is 92 available? Also, with RPI, you don't need to "export" the GPIO, just tell rpi which GPIO to use and it does the work for you:

From my /etc/rc.local:

/usr/local/bin/rpi_gpio_ntp -N 1 -g 2

Here I am specifying GPIO 2.

You can also test by doing the following:

root@Wilcutt:~# rpi_gpio_ntp -N 1 -g 2 -d
rpi_gpio_ntp v1.5, (C) 2013-2015 by folkert@vanheusden.com

NTP unit : 1
GPIO pin : 2
GPIO pout: -1
Fudge : 0.000000000
"Fork into the background" disabled because of debug mode.
1528637369.482893215] interrupt #1, 0 wraps, offset 0.482893s nan/0.482893/nan
1528637370.482790391] interrupt #2, 0 wraps, offset 0.482790s 0.482790/0.482842/nan
1528637371.482779647] interrupt #3, 0 wraps, offset 0.482780s 0.482785/0.482821/nan

Again, my GPIO is #2.

I'm going to guess your GPIO pin is not a good one to choose.


Who is online

In total there is 1 user online :: 0 registered, 0 hidden and 1 guest (based on users active over the past 5 minutes)
Most users ever online was 5185 on Wed Jan 22, 2020 1:44 pm

Users browsing this forum: No registered users and 1 guest