Power & Source of Big Ideas

Missing USB keyboard

Moderators: chensy, FATechsupport

So, after installing the Friendlycore image (s5p6818-sd-friendlycore-xenial-4.4-arm64-20190718.img) the attached USB keyboard is not detected..

[list=]
[*]The keyboard works fine on a Mac, so it's definitely functional. I even tried more than one of them.
[*]There is a USB mouse plugged into the keyboard (it's an Apple keyboard with an integrated hub) and the mouse is detected and works just fine
[/list]

If (after boot) I look in /dev/input I see:

Code: Select all

lrwxrwxrwx 1 root root 9 Oct  8 17:23 platform-c0030000.ehci-usb-0:1.3:1.0-event-mouse -> ../event2
lrwxrwxrwx 1 root root 9 Oct  8 17:23 platform-c0030000.ehci-usb-0:1.3:1.0-mouse -> ../mouse1
lrwxrwxrwx 1 root root 9 Oct  8 17:23 platform-gpio_keys-event -> ../event1


.. so only mouse-based input sources and the 'gpio_keys' "keyboard". No trace of the USB one.

Is this an overlay thing ? Do I need to tell it to use the USB keyboard somehow ?

Attaching the boot log ...
bootlog.zip
Boot log
(8.88 KiB) Downloaded 73 times
and the X server log

Attachments

So, talking to myself here, but the problem is solved in the most-recent image from Google Drive (s5p6818-sd-friendlycore-xenial-4.4-arm64-20190930.img)

Now if I list /dev/input/by-path, I see:

Code: Select all

root@NanoPi-Fire3:/dev/input# tree
.
├── by-id
│   ├── usb-Apple__Inc_Apple_Keyboard-event-if01 -> ../event4
│   ├── usb-Apple__Inc_Apple_Keyboard-event-kbd -> ../event3
│   ├── usb-Logitech_USB-PS_2_Optical_Mouse-event-mouse -> ../event2
│   └── usb-Logitech_USB-PS_2_Optical_Mouse-mouse -> ../mouse1
├── by-path
│   ├── platform-c0030000.ehci-usb-0:1.2:1.0-event-kbd -> ../event3
│   ├── platform-c0030000.ehci-usb-0:1.2:1.1-event -> ../event4
│   ├── platform-c0030000.ehci-usb-0:1.3:1.0-event-mouse -> ../event2
│   ├── platform-c0030000.ehci-usb-0:1.3:1.0-mouse -> ../mouse1
│   └── platform-gpio_keys-event -> ../event1
├── event0
├── event1
├── event2
├── event3
├── event4
├── mice
├── mouse0
└── mouse1


So the keyboard is all linked up and the X server sees it just fine.

Who is online

In total there are 3 users online :: 0 registered, 0 hidden and 3 guests (based on users active over the past 5 minutes)
Most users ever online was 5185 on Wed Jan 22, 2020 1:44 pm

Users browsing this forum: No registered users and 3 guests