Power & Source of Big Ideas

How to change Fire3 LCD resolution

Moderators: chensy, FATechsupport

The wiki says to compile a new kernel and only lists 3.4.y but it's running on 4.4.49-s5p6818 from

The screen resolution needed is 800x480 and I originally booted with a LCD that failed.

From Xorg.o.log:-
9.856] Kernel command line: console=ttySAC0,115200n8 root=/dev/mmcblk0p2 rootfstype=ext4 rootwait init=/sbin/init loglevel=7 printk.time=1 consoleblank=0 lcd=HDMI720P60 bootdev=2

[ 13.698] (II) modeset(0): Printing probed modes for output HDMI-1
[ 13.698] (II) modeset(0): Modeline "1280x720"x60.0 74.25 1280 1390 1430 1650 720 725 730 750 +hsync +vsync (45.0 kHz eP)
[ 13.698] (II) modeset(0): Output LVDS-1 disconnected
[ 13.698] (II) modeset(0): Output HDMI-1 connected
[ 13.699] (II) modeset(0): Using exact sizes for initial modes
[ 13.699] (II) modeset(0): Output HDMI-1 using initial mode 1280x720 +0+0

Does this mean I have to reinstall in order to have 800x480 resolution?
I tried s5p6818-friendly-core-xenial-4.4-arm64-20180228.img but Xorg ends up as a zombie task.
Went back to the original microSD card with s5p6818-friendly-core-xenial-4.4-arm64-20180209.img installed.

Still getting a white screen with Xorg up and running.
Over an ssh login "init 3" followed by "init 5", login screen came up and logged in as root to a mate desktop.
May be a race condition when booting straight into X?

Loging in as fa and pi tried first - refused.

Screen resolution is OK but Xorg.0.log shows the same as before. Possibly it's not a 800x480 7 inch screen i ordered but got a 1280x720 instead.

[ 350.861] (II) modeset(0): Using exact sizes for initial modes
[ 350.861] (II) modeset(0): Output HDMI-1 using initial mode 1280x720 +0+0
[ 350.861] (II) modeset(0): Using default gamma of (1.0, 1.0, 1.0) unless otherwise stated.
[ 350.862] (==) modeset(0): DPI set to (96, 96)
Hie.. is anyone got success for changing resolution from 1280x760 to 800x480...???
please give some suggestion...... how to achieve 800x480 resolution on HDMI screen
If the HDMI display you are using has native resolution of 800x480 and has the EDID connection with the details, it should automatically adjust itself.

You also don't state which OS you are using? The HDMI settings should also be in the Wiki.
oot@NanoPi-M4v2:~# cat /etc/os-release
VERSION="18.04.3 LTS (Bionic Beaver)"

I changed the default setting to 800x480@60Hz but got no output.

The 10.1 inch LCD supports 1920x1080 and that worked straight away as does touch.
screen #0:
dimensions: 1920x1080 pixels (508x285 millimeters)
resolution: 96x96 dots per inch
depths (7): 24, 1, 4, 8, 15, 16, 32
root window id: 0x409
depth of root window: 24 planes
number of colormaps: minimum 1, maximum 1
default colormap: 0x20
default number of colormap cells: 256
preallocated pixels: black 0, white 16777215
options: backing-store WHEN MAPPED, save-unders NO
largest cursor: 64x64
current input event mask: 0xfa8033

Who is online

In total there are 4 users online :: 0 registered, 0 hidden and 4 guests (based on users active over the past 5 minutes)
Most users ever online was 5185 on Wed Jan 22, 2020 1:44 pm

Users browsing this forum: No registered users and 4 guests