Power & Source of Big Ideas

IP Table Not working

Moderators: chensy, FATechsupport

Hi folks,

I want to use ip table in my build. But, whenever I am trying to use the ip table it is not working.
It is throwing an error :

modprobe: FATAL: Module ip_tables not found. iptables v1.4.21: can't initialize iptables table `filter': Table does not exist (do you need to insmod?) Perhaps iptables or your kernel needs to be upgraded.

I am not getting anything specific to solve this error over the internet.
So help me out in solving this error.
Any help is highly appreciated.

Thank You.
What does lsmod say?

Which board are you working on and what OS?
Hi Dave,
OS is ubuntu.
ismod is not working here.
It is limited os with only required commands and features.
lsmod, ie list modules ... not ismod
Module Size Used by
imx_ipu_scaler 8403 0
snd_soc_imx_tlv320aic32x4 2648 0
imx_ipu 5562 1 imx_ipu_scaler
snd_soc_tlv320aic32x4 16784 1
snd_soc_imx_audmux 5853 0
imx_sdma 12927 2
coda 47335 0
snd_soc_fsl_ssi 12171 2
videobuf2_vmalloc 4865 1 coda
videobuf2_dma_contig 9320 2 coda,imx_ipu_scaler
snd_soc_fsl_asrc 16147 0
imx_pcm_fiq 3790 1 snd_soc_fsl_ssi
imx_pcm_dma 1151 1 snd_soc_fsl_ssi
videobuf2_memops 2138 2 videobuf2_vmalloc,videobuf2_dma_contig
v4l2_mem2mem 14069 2 coda,imx_ipu_scaler
videobuf2_core 42618 3 coda,v4l2_mem2mem,imx_ipu_scaler
gpio_keys 8986 0
gpio_beeper 1981 0
OK, lsmod was not helpful.

You didn't say which board you are working on. Also, I don't recall of anyone running Ubuntu on these boards. I ran Debian Jessie on the NanoPi for a year or so.

Have you tried:

sudo apt-get install iptables

Who is online

In total there are 4 users online :: 0 registered, 0 hidden and 4 guests (based on users active over the past 5 minutes)
Most users ever online was 5185 on Wed Jan 22, 2020 1:44 pm

Users browsing this forum: No registered users and 4 guests