Power & Source of Big Ideas

NanoPi WiFi problem

Moderators: chensy, FATechsupport

Seems a number of us are having the same problem trying to access certain APs. Refer to this thread for details:

Appreciate your comments.

Hi davef,

Thank you.
We have to admit that the overall performance of the NanoPi WIFI is not very good.

As for the AP issue you can try removing the connector shown below and solder an antenna
NanoPi.png (246.74 KiB) Viewed 6294 times

As for the wifi client issue our Debian by default is set to WPA so if the AP is WPA2 it might not work. You can set it to WPA2 and try again.
Signal strength is not the problem.

wpa_cli -iwlan0 scan_result shows -37 (dBm) as the NanoPi is about 1 meter away from the Wireless router. Also, I had tried WPA2 with no result.

I will try again in a few days.
Looking at the first error message:
[10347.440300] dhd_preinit_ioctls buf_key_b4_m4 set failed -23

and in dhd_linux.c

at line 3979 one will find the text in the error message:
"buf_key_b4_m4 set failed"

There is no comment before:

bcm_mkiovar("buf_key_b4_m4", (char *)&buf_key_b4_m4, 4, iovbuf, sizeof(iovbuf));

So, maybe someone who understands what this function is doing could suggest what the problem is.

Line 4097 has the text for the 2nd error message:

Can't find where:

is located, however maybe resolving the first error message will eliminate the others.

Later on: these error messages even exist when it does connect properly ... so ignore this post.
Hi davef

Thank you very much for your observation. We are doing some tests now and will release some results
Well, after successfully accessing another two Smartphones and another wireless router, I tried my TP-LINK again and now it works.

Following an example on Ubuntu help pages, I put:

wpa_proto WPA RSN

see https://help.ubuntu.com/community/NetworkConfigurationCommandLine/Automatic and the section WPA supplicant.

I read somewhere else that RSN = WPA(2) so having to put both seems redundant.

I am moving on to the next problem.
Thank you davef.
We did several tests here and we followed the steps on our wiki and could connect to our router. Our router is NETGEAR R6300V2 and is set to "WPA2-PSK[AES]"

Who is online

In total there is 1 user online :: 0 registered, 0 hidden and 1 guest (based on users active over the past 5 minutes)
Most users ever online was 5185 on Wed Jan 22, 2020 1:44 pm

Users browsing this forum: No registered users and 1 guest