Hi. I've some Nano PI M2 and I'n not able to boot with whichever linux image.
I've tried Fryendlycore, both 20210324 and 20171212 version, lubuntu-xenial version 20210324 and I always get the same output (taken from UART 0, no console is connected):
-----------------------------------
BL1 by Nexell V1.0.0-gd551e13 [Built on 2018-01-25 16:58:29]

Memory Initialize (0) Done.

Loading from sdmmc...
Image Loading Done!
Launch to 0xB0FE0400


U-Boot 2016.01-00041-ga7bea11237 (Nov 08 2019 - 16:56:31 +0800)

Model: FriendlyElec boards based on Nexell s5p4418
Board: s5p4418-X
DRAM: 1020 MiB
Panel: N/A (-1)
MMC: NEXELL DWMMC: 0, NEXELL DWMMC: 1
HDMI: display.0, preset 0 (1280 * 720)
HDMI: phy ready...
LCD: [HDMI] dp.0.1 1280x720 32bpp FB:0x77000000
In: serial
Out: serial
Err: serial

Hit any key to stop autoboot: 0
6165728 bytes read in 430 ms (13.7 MiB/s)
5880768 bytes read in 400 ms (14 MiB/s)
** File not found s5p4418-nanopi2-rev05.dtb **
libfdt fdt_check_header(): FDT_ERR_BADMAGIC
Kernel image @ 0x71080000 [ 0x000000 - 0x5e14e0 ]
ERROR: Did not find a cmdline Flattened Device Tree
Could not find a valid device tree
nanopi2#
-----------------------------------------
The error is always the same, also with different SD cards.
This behavior changes if I try ubuntu-mate version 20170113: with this version the PI M2 starts regularly and remains up and running if connected only to UART 0 but, if I connect a HDMI monitor with a USB Keyboard and a USB mouse it keeps rebooting after showing "FriendlyArm" splash screen and login request, and the CPU becomes immediately very hot (I've put an heatsink over it, but the problem is the same). Could someone help me? Thanks in advance
Tiziano