Power & Source of Big Ideas

Compile android kitkat source

Moderators: chensy, FATechsupport

Hello!
I am trying to compile android sources following the guide on FriendlyArm Wiki.
Compilation ends without error and all images get generated well (boot.img, cache.img, userdata.img, system.img).
The problem is that my nanoPC T2/T3 doesn't boot... The board stuck on the initial logo.
I have tried flashing via fastboot and sd card without luck.

What i'm doing wrong?
Thanks in advance
You need to capture the serial output during the boot sequence. This will show you what is going wrong.

My suspicion is with the eMMC as there was a fix to handle an update. Have a look at this link and check if your source has these changes. It is in the Linux kernel so make sure you rebuild that and then replace the one in the Android source.

https://github.com/friendlyarm/linux-3. ... ebb23bb0b3

I saw this in the boot sequence.

Code: Select all

[    0.000000] Linux version 3.4.39-FriendlyARM (gcc version 4.9.3 (ctng-1.21.0-229g-FA) ) #20 SMP PREEMPT Tue Jun 26 22:45:49 WIB 2018
...
[    3.568000] mmc0: unrecognised EXT_CSD revision 8
[    3.568000] mmc0: error -22 whilst initialising MMC card
Many thanks v8dave.
As you have seggested, i have captured the kernel log (see attachment).
It seems not to be an mmc issue...

Any help is very well appreciated.

Attachments

The boot seems to go well until this at the end and it looks like the FS failed to mount. Did you install Android to the eMMC or running from SD card?

Code: Select all

[   23.004000] fs_mgr: Cannot mount filesystem on /dev/block/platform/dw_mmc.0/by-num/p2 at /system
[   23.012000] init: fs_mgr_mount_all returned an error
[   23.040000] init: /dev/hw_random not found
[   23.044000] init: Unable to open persistent property directory /data/property errno: 2
[   23.060000] init: cannot find '/system/bin/servicemanager', disabling 'servicemanager'
[   23.064000] binder: 95:95 transaction failed 29189, size 0-0
[   23.076000] init: cannot find '/system/bin/vold', disabling 'vold'
[   23.080000] init: cannot find '/system/bin/netd', disabling 'netd'
[   23.088000] init: cannot find '/system/bin/debuggerd', disabling 'debuggerd'
[   23.092000] init: cannot find '/system/bin/rild', disabling 'ril-daemon'
[   23.100000] init: cannot find '/system/bin/surfaceflinger', disabling 'surfaceflinger'
[   23.108000] init: cannot find '/system/bin/app_process', disabling 'zygote'
[   23.116000] init: cannot find '/system/bin/drmserver', disabling 'drm'
[   23.124000] init: cannot find '/system/bin/mediaserver', disabling 'media'
[   23.128000] init: cannot find '/system/bin/installd', disabling 'installd'
[   23.136000] init: cannot find '/system/etc/install-recovery.sh', disabling 'flash_recovery'
[   23.144000] init: cannot find '/system/bin/keystore', disabling 'keystore'
[   23.152000] init: property 'ro.product.manufacturer' doesn't exist while expanding '${ro.product.manufacturer}'
[   23.164000] init: cannot expand '${ro.product.manufacturer}' while writing to '/sys/class/android_usb/android0/iManufacturer'
[   23.176000] init: property 'ro.product.model' doesn't exist while expanding '${ro.product.model}'
[   23.184000] init: cannot expand '${ro.product.model}' while writing to '/sys/class/android_usb/android0/iProduct'
[   23.236000] init: property 'sys.powerctl' doesn't exist while expanding '${sys.powerctl}'
[   23.244000] init: powerctl: cannot expand '${sys.powerctl}'
[   23.248000] init: property 'sys.sysctl.extra_free_kbytes' doesn't exist while expanding '${sys.sysctl.extra_free_kbytes}'
[   23.260000] init: cannot expand '${sys.sysctl.extra_free_kbytes}' while writing to '/proc/sys/vm/extra_free_kbytes'
[   23.272000] init: cannot find '/system/bin/sh', disabling 'console'
[   23.276000] init: cannot find '/system/bin/report_hwc_scenario', disabling 'reporthwc'
[   23.284000] init: cannot find '/system/bin/report_hwc_scenario', disabling 'reporthwc'
[   23.292000] init: cannot find '/system/bin/report_hwc_scenario', disabling 'reporthwc'
[   23.300000] init: cannot find '/system/bin/report_hwc_scenario', disabling 'reporthwc'
After some investigations, i am sure that the compiled boot.img try to mount file system from sd and not eMMC.
May you help me on fix the issue?
I don't know how modify boot to read from eMMC and not from SD card...

Thank you!

Who is online

In total there are 15 users online :: 0 registered, 0 hidden and 15 guests (based on users active over the past 5 minutes)
Most users ever online was 825 on Wed Aug 28, 2019 3:18 pm

Users browsing this forum: No registered users and 15 guests