Power & Source of Big Ideas

usb speed low

Moderators: chensy, FATechsupport

I use a NEO2 (H5), with armbian linux 4.19.13-sunxi64, and also with friendlycore-xenial_4.14_arm64, and have a StarTech usb2.0 to Gigabit-ethernet adapter, which I plug in the usb slot of the NEO2 and which gives me a new additional ethernet interface.

iperf3 on this interface (against another NEO2 with its generic gigabit interface) gives maximum 111 MBit/sec, even with the tips in https://forum.armbian.com/topic/7001-sl ... r-related/ (which actually dont change much)

Using a raspberry pi (2B) with the same adapter and cable I get 170 MBit/sec, which is significantly more (although still not what one should hope for, which is up to 300, but maybe the StarTech is not perfect)

So the usb adapter is not the problem, and I observe similar speeds (around 100 MBit/sec) with other devices too, and with both images, armbian and xenial.

Why is the usb in the H5 so slow? I need at least 150MBit/sec (ok not really for this adapter, actually for another one, but never mind)
if I put an ip address in the section s.connect(('10.255.255.255', 1)) that is valid on the subnet the nanopi receives it ip address in (ie 12.1.1.1, which does not actually exist) then it displays the ip address that was assigned to by DHCP.

Who is online

In total there are 5 users online :: 0 registered, 0 hidden and 5 guests (based on users active over the past 5 minutes)
Most users ever online was 2865 on Sun Nov 10, 2019 5:27 am

Users browsing this forum: No registered users and 5 guests