Power & Source of Big Ideas

nanopi neo4 wifi and Bluetoof not working

Moderators: chensy, FATechsupport


I installed rk3399-eflasher-android8-20190718 on my neo4.

wifi and Bluetooth is not working
same issue .. i finally got the android 8 build working and flashed, but now the wifi does not work .. i know the hardware works becausei tried it on the image that came with the eMMC module ... but after i flashed a newly built android 8 system (unmodified), and updating the Nanopi M4V2 board, wifi no longer works .. no response on this since Sept .. wow .. anyone at FriendlyElec that can help? Can someone at FE build android8 and flash a NanoPi M4V2 and see if it works?
lots of errors in build not sure which are important, but wifi does not work .. any ideas?

Nanopi M4V2 board, android 8.1 build (no changes made)

serial output attached


I had a look at your log file and I saw the same on my build. I am using the exact same source as you with only minor changes to remove the desktop icons and change the init.rc to make GPIO user space access.

The attached debug output shows what I see when I activate wifi on the T4 (this has the same hardware as the M4V2).

Can you capture and upload what the debug output shows when you go to Wifi settings and turn it on.

PS. Many of the errors in the debug output is normal. This AVC DENIED is SELINUX output but that is set to permissive which means it doesn't stop anything working but will show its output for the developer to take care of in the release version.


i will check and post .. the toggle switch does not slide to the on position but there was no visible error in Android .. i will check the debug output and post
The toggle switch not sliding means there was no physical hardware present. I see this on the NanoFire3 which has no WiFi chipset. We may have to dig deeper into the debug output.

Another useful log to check and capture of the logcat. From the same terminal, type in logcat and it will spit out the full Android debug. Normal terminal is what you see with dmesg.
I will get the log tonight .. note that this is using the latest 8.1 branch from friendlyarm with no modifications on the nanopi-m4v2 board ... the hardware did work with the android on the eMMC module so something seems wrong with the android 8.1 branch ... i will get the log and post today
attached log file from logcat


I would also note during the build, if i ran ./build-nanopc-t4.sh with -W option (i belueve it was) ,.. it said it would generate outptut .ko files in a certain directory but it did not generate anything there ... the build all option -F -M is suggested which is what i did and that did not generate it either
Your log file is missing. Opening it shows com.apple.quarantine so suspect your computer has blocked this file.
strange thank you attached again


Can you look in /vendor/lib/modules/wifi and see if the bcmdhd.ko file is present?

When I list that directory, I get these files. You mentioned before that the .ko files were not being built.

8188eu.ko 8189es.ko 8723bs.ko 8723cs.ko 8822be.ko
8188fu.ko 8189fs.ko 8723bu.ko 8723ds.ko bcmdhd.ko
that directory does not exist
under vendor the only dir called wifi is vendor/rockchip/common/wifi and they are not there

there is no lib under vendor
is someone going to fix the build system so that these boards can be used?
Under the source for the Android build, if you search for .ko do you find any files?

There should be at least a file called mali_kbase.ko in /vendor/rockchip/common/gpu/MaliT860/lib/modules in the source tree.

In the /vendor/rockchip/common/gpi directory there is a MaliT860.mk file and opening this shows that it copies the mali_kbase.ko files to the vendor/lib/modules directory.

I have the same source as you have but I have some customisation but it should build the same. Do you use the -F -M build arguments? That builds everything including making the images.
I did build with those flags yes, I will do it again and post the output but it did not work it seems .. have you tried building from scratch?

Who is online

In total there are 2 users online :: 0 registered, 0 hidden and 2 guests (based on users active over the past 5 minutes)
Most users ever online was 5185 on Wed Jan 22, 2020 1:44 pm

Users browsing this forum: No registered users and 2 guests