Page 1 of 1

Android not booting from emmc

Posted: Thu Nov 15, 2018 9:14 am
by thk4711
Hi,

I am trying to use Android on a M4. I did use etcher and win32diskimager to write the Android 7 and the Android 8 image to the emmc flash device using the adapter which came with it. This is working and I am also able to see the 2 partitions on the device after the flashing. If I am trying to boot Android I only see the Friendly ELEC logo for a short time an the the monitor is turning black again and the green LED is flashing.
Linux on the SD card is working without problems.
What can I do here ?
Thomas

Re: Android not booting from emmc

Posted: Fri Nov 30, 2018 1:56 pm
by thk4711
I am not sure what I should do by "Recover your eMMC first". In Linux I can access the eMMC storage. I filled it up in Linux and read it back. That worked. In the meanwhile I also tried a eMMC Linux image. This did also not boot.

Re: Android not booting from emmc

Posted: Wed Dec 12, 2018 2:34 am
by kckndrgn
Android does not boot for me either. I get the Friendly screen logo then a blank screen. Nothing after that.

Trying one of the lubuntu emmc distros now.

What does it mean to "recover" the emmc?

Re: Android not booting from emmc

Posted: Sat Dec 15, 2018 2:33 pm
by avensis
Hi, Android does not start for me either with emmc, how to recover emmc ?


________________________________________________________________________________________________
Torrent https://downloader.vip/vpn/ Tutuapp

Re: Android not booting from emmc

Posted: Sat Jan 05, 2019 3:49 pm
by pebol
Same for me. Is there a solution? And what does recover mean? Erasing and formatting the emmc?

I found a "typec image" in the download section. How is this image transferred to the emmc? Via the USB C socket of the board?

Re: Android not booting from emmc

Posted: Sat Jan 12, 2019 3:27 pm
by pebol
Hm, no reply up to now. I am a bit disappointed. The M4 is a real powerful and nice piece of hardware but without a fully functioning Android on emmc it is not of much use to me. Well, I knew it's a development board and that this means, some software has still to be developed .....

Re: Android not booting from emmc

Posted: Wed Jun 12, 2019 12:17 pm
by vko
I had a similar situation with a linux image not booting from emmc module, if I flash it directly first using the microsd adapter. I then flashed an eflasher image to a microsd card, and followed the prompts to flash the emmc, removed the microsd card, and it boots up perfectly fine from emmc module.

Question remains, what is the typec image for?

Re: Android not booting from emmc

Posted: Fri Jul 12, 2019 12:59 pm
by amzoun95
NVM. I got it working with a new image 4.4.4













Dafont Showbox Adam4adam