Power & Source of Big Ideas

Why is rooting the NanoPI-T4 Android not more important?

Moderators: chensy, FATechsupport

Hello all!

The title speaks for itself - I am wondering why there isn't a larger move towards rooting this thing? It's a development board; yet there is no root available for this system. Maybe we could research as a whole how to get this done?
Hey, still no answers for that please?

_________________________________________________________________________
UC Browser SHAREit MX Player
Nope... no answers. It's really confusing why this board would have so many features without a way to really tap into its potential.
If you build the source and choose the USERDEBUG version (default), you have full root access.
v8dave wrote:
If you build the source and choose the USERDEBUG version (default), you have full root access.


This does not seem to be true. I have userdebug enabled on my build (I built following the instructions so I have a default build, I also checked in "about this phone, it says userdebug in the build number). None of the apps I have installed that require root seem to think they have root access...
v8dave wrote:
I wonder if this will help you?

https://stackoverflow.com/questions/559 ... -superuser


Unfortunately it didn't help much. Seems like the info is too old to work with Nougat.

You know the odd thing about all this is I can use Magisk just fine to root a FireFly RK3399 based board but it does not recognize the boot image format for the NanoPC. It seem that the NanoPC uses an older format than what RockChip supports now, and the FireFly uses UEFI boot.

Basically friendlyelec needs to modernize the boot process for their boards and follow the new rockchip way of doing things with uefi and things would just work fine...

http://opensource.rock-chips.com/wiki_Boot_option

Unfortunately it does not seem that friendlyelec keeps their code up to date.. So I do not think this will happen any time soon.
To answer your question: Yes, Rooting is very important!

There are many apps which require root-access, and especially for a device like this - a device for (android) developers - this should be a no-brainer!

I have a NanoPC-T4, and just found out ....
Yeah it's actually very disappointing.
Hi guys,

Userdebug only means that you can get root access via adb.

1) Regarding the boot.img:
By default the boot.img does not contain the kernel. Change the targed in "device/rockchip/common/mkimage.sh" to

Code: Select all

TARGET="ota"

to get a boot.img which you can patch with Magisk and flash.

2) To embed SuperSU inside the custom ROM before building I succeeded to obtain root access (using Nougat) by embedding
https://github.com/khadas/supersu into my FriendlyARM ROM.

If you need further help let me know.
Thanks!
This is really good news!

Too bad, somehow I am stuck ..
I compiled a boot-image including kernel, and it works.
When installing Magisk I can create a patched-boot-image, but here my problems start:
How do I install it?
I tried to go into 'fastboot mode' by 'adb reboot bootloader', and by pressing the boot-button when switching on the device, but all I see is a black screen, and fastboot tells me 'waiting for device'.
I tried flashing the patched-boot-image with the RKDevTool, but end up in Recovery mode.

There is no TWRP for the NanoPC-T4, so I am stuck ...

Any idea?
Then try embedding SuperSU instead. That works for sure!

The steps are:
1. Put the downloaded files into /vendor/root (make sure that you also copy the hidden file!)
2. Change root.mk: replace "vendor/amlogic/root" by "vendor/root"
3. Add also the line "vendor/root/su:system/xbin/su \"
4. Add "PRODUCT_PACKAGES += SuperSU" at the end of that file
5. Now go into the folder "SuperSU" and change "LOCAL_CERTIFICATE := PRESIGNED" to "LOCAL_CERTIFICATE := PLATFORM" inside "Android.mk"
6. Modify "/device/rockchip/rk3399/nanopc_t4.mk" by adding "$(call inherit-product-if-exists, vendor/root/root.mk)"

And then recompile (you don't need to clear the entire output directory).
I hope I did not miss anythink.
Great! It's working for Android 8.1!

When compiling there was in issue with: "ninja: error: 'build/target/product/security/PLATFORM.pk8', needed by 'out/target/product/nanopc-t4/obj/APPS/SuperSU_intermediates/package.apk', missing and no known rule to make it". I copied the existing 'build/target/product/security/platform.pk8' to 'build/target/product/security/PLATFORM.pk8'. With the same for PLATFORM.x509.pem and PLATFORM.pem.

After these changes compilation went smoothly.

When running SuperSu it's asking to update the su-binary, which is not working. But this does not cause any problems.

Thank you so much for your help! :D :D :D
You are welcome, glad it works!
Last time I checked (a few years ago) Rockchip wasn't really elec friendly, since they used a homemade custom build and weren't releasing the source for their modifications as the license requires. Any changes on this side of the company politics?
We should not expect any support from Friendlyarm ...

This is what I received from techsupport@friendltarm.com when asking about rooting:

"Should not be root, I don't know why you want to root, if you need to access hardware resources, you can actually do it without root, you can check it out here: http://wiki.friendlyarm.com/wiki/index. ... for_RK3399"
and
"Because this violates the rules of android and will make your device unsafe."
You have access to the Andoird and Android Linux source so you can potentially do anything you want right there. You can add in any SU apk and have this as part of the build. Make other changes for security etc.

I recently needed a way to shutdown the Android device from code and I made changes to the source to bypass the security level that only allowed SYSTEM APPS to do this and now I can shutdown the system from a standard app. As the device is for a fixed product, this works well. I also added double tap to wake for Android 5.1 on the Nano PC T3 Plus as part of the Linux kernel.

I've downloaded and can build the RK3399 Android 8 and already making some changes to the OS to support double tap to wake as I did with the above Nano PC t3 Plus.

If you don't know how to build the source, it's not too hard if you follow the instructions on the wiki. I use a laptop with Ubuntu 12.04 but you can also build within a VM running 12.04 too.

Who is online

In total there are 2 users online :: 0 registered, 0 hidden and 2 guests (based on users active over the past 5 minutes)
Most users ever online was 102 on Mon Oct 08, 2018 12:42 pm

Users browsing this forum: No registered users and 2 guests