Power & Source of Big Ideas

Dual MCAM400 support

Moderators: chensy, FATechsupport

I would like to work with two MCAM400 modules on a nanopi M4 in parallel. I read that this should be possible with the latest Image containing isp1. Is that right?
Can someone please provide a minimum working example for capturing both images to files.

Best regards
Harandk wrote:
Can someone please provide a minimum working example for capturing both images to files.

It's included in distro as a GStreamer bash script - dual-camera.sh
escobarrr wrote:
I didn't find it in distro, can you please help me ?

- you need a 201905xx friendlyelec distro (installed from scratch to be sure, and Desktop (you will not see second cam output in terminal\Core))
- type `which dual-camera.sh`
Still no working dual camera support even with the latest (20190625) version and I think I'm not the only one.
The csi1 connected camera is extremely slow and distorted.
Harandk wrote:
Still no working dual camera support even with the latest (20190625) version and I think I'm not the only one.
The csi1 connected camera is extremely slow and distorted.


Well, looks like it's working, but with stability issues.

Take a time to look at 'dmseg' output - it may look like this errors- showed for both old(isp10) and new(isp1) drivers. If you have similar errors - this is hardware stability issue (FriendlyElec develop & release both T4 & M4 without having working drivers to test Dual-camera mode).

It was some discussion in kernel thread about decreasing ISP frequency to increase stability, but it is no conformation about success.

Who is online

In total there are 6 users online :: 0 registered, 0 hidden and 6 guests (based on users active over the past 5 minutes)
Most users ever online was 5185 on Wed Jan 22, 2020 1:44 pm

Users browsing this forum: No registered users and 6 guests