Power & Source of Big Ideas

Enable usb3 on nanopi m4

Moderators: chensy, FATechsupport

hello i want to activ usb3 on nanopi m4, how i can do this? the distro i use is friendlyelec 64 cordially ;)
it's active by default (otherwise non of USB ports will work - since they connected via a USB3 hub to Rk3399).
thank you for your answer but why my ssd of 1to is recognized in usb2 I checked in lsusb and other devices are in usb2 and even I made transfers on it that are slow not to the speed usb3 while on a computer windows I get more than 100mo / in music transfer but under the nanopi I have no speed but it shows that it's slow cordially
Ps:sorry for my english :D :D
I made a pc benchmark with gnome disk utility and I have 360mo / s write and transfers are slow weird so it must work in usb3 but transfers are slow it's weird :?
As I mention, it's a USB3 hub on M4 - so you shouldn't expect a full speed of USB3 from every port.

A correct way to check USB3 - performance must be even higher, than theoretical maximum for USB2 - which is around 60MB\s for read\write.


You may find more information on performance thread (but with armbian 4.19) - https://forum.armbian.com/topic/8097-na ... on-review/

"In the "IO performance" chart, NanoPi M4 + JMS578 + 850 EVO is connected via USB 3.0. So the performance is about 388/300 MB/s and 70k/99k IOPS (read/write)."
"But on NanoPi M4 there's always the internal VIA VL817 hub in between SuperSpeed devices and USB3 host controller and this usually affects performance as well. "
ok thank you very much ;)

Who is online

In total there are 5 users online :: 0 registered, 0 hidden and 5 guests (based on users active over the past 5 minutes)
Most users ever online was 825 on Wed Aug 28, 2019 3:18 pm

Users browsing this forum: No registered users and 5 guests