Power & Source of Big Ideas

Impression on my new NanoPC-T4, linux stuff and my thoughts

Moderators: chensy, FATechsupport

Hello. Finally I have my SBC, nice and shiny. Beautiful, so small, packed with all I needed. Thank you friendlyarmers, you deed a good hardware work.

I don't know what OS was installed in emmc, it just didn't work (I think it was Android, some android debugging message flipped once), so I had to install Android (image from frendlyarms googledrive). Well, it works, nothing special, no "Wow"s. Screen settings menu doesn't work, so I cant switch to 1080p resolution, have to watch at monitors default 1380x760. But running a mobile OS as "desktop" is not fun, even if you just playing games. Keyboard on half of 24' screen isn't fun to. and keyboard layout switching... no matter what language i set on onscreen keyboard, physical keyboard types only latin... Adblock browser hangs computer. No, running Android on desktop is a pain.

So I had to install Lubuntu (2018.08.14 build). Maaan, it's a nightmare. Wireless constantly reconnecting spitting errors in dmesg. Qt player doesn't play a demo provided on image. everything just hangs, so I have to reboot. Openbox works worse than on ancient thinclient with 256MB memory and Sis videochip on vesa driver. Terrible. But I have read, that X11 support on Arms is bad. Ok, will look for composite managers, or even Wayland stuff later. Minetest didn't run. It misses OpenGL. it was compiled without OpenGL ES in arm repository??? Why the hell it is in repo at all then? Ubuntu devs do not check is it working at all? or it is because of this custom built image and custom drivers? All packages are so old... 16.04... Why Arm SBC users must suffer so hard? Removed this outdated buggy ugly Lubuntu.

Ubuntu Core 18.04. First I checked how wifi is working. it's Ok. But it somehow works only in slow 2.4 regime, not in 5.0, but at least it is stable. Checked Qt demos mentioned on NanoPC's wiki, buggy. some works, some not. In fact only player and browser works. Upgraded everything, installed Weston to check how Wayland is working, Nice, smooth, but... there is no lightweight Wayland DE in repo? no modern Enlightenment, no Liri, no nothing, just Weston and monstruoso Gnome and KDEs Plasma sessions on Wayland are available. I installed plasma. it didn't work on Wayland, but at least worked on X11. And quite smooth, compared to Lxde on Lubuntu 16.04 (oh... this myth about Lxde's lightweightness and speed).

Ok, I've got KDE running on Arm, isn't it great? Yes! and... No. because it becomes boring just watching at desktop. I need to play videos, web with youtube and facebooks, I need to run Minetest, Extremetuxcart, and all that stuff!

First installed Smplayer with youtube addon. What can I say, I'm watching videos, smooth. VLC (with manualy set gles backend) works smooth to. I don't need no hacks, no special secret options, briliant, Bravo!

With browsers is not so fun. My thoughts was - if friendlyarm provides prebuilt patched version of Qt and gstreamer and KDE runs so smooth, then maybe I could use some Qt based browser? Installed Falkon (ex Qupzilla), by the way, KDE installed Konquerror, so I checked them both. Well, don't know about overall browsers acceleration, but video acceleration doesn't work here, even 360p is choppy on fullscreen. Worst on that, when I tried Qt-browser from friendlyarms precompiled examples - it switched my screen and died. I had to manually switch to right VT by Ctrl+Alt+Fsomething. Not good. Something in updated system and added packages that came with KDE broke this static(as I thought) build. Hm. and... why I can't use this prebuilt patched Qt systemwide? If your Qt would be properly packaged as system library package and all packages depending on Qt and gstreamer would be rebuilt in your local repository, or at least in PPA. Is it possible?

Games. First and main thing children always asking me is Minetest (not Minecraft, true opensourcers) :) Installed it (with all dependencies, of course) and bumped to the same problem - it wants an OpenGL. You are serious? Anybody uses this package at all? A simple game! Do I ask to much? I didn't try other games, or graphic packages, because now I see. in Ubuntu nobody cares about working apps. (or your build is so bad?)

I know that it is mainly a devboard, and I will use it later as a devboard for my project with my children (but now I am affraid that I will bump into problems again), but hardware made such huge step forward, it is so powerful, but without a good software it's just a brick. My conclusion is - I bought myself a powerful, beautiful, 120€ brick with videos in it, not more. Desktop background wallpapers watcher. Had to put Android back for children for now, at least they can play Minetest, weird controls, but it works. at least...

As for a software and distribution you choose: Why Ubuntu? Why not making your own Arch repo, which contains only apps that this computer supports? You still had to build your own Qt library incompatible with the rest Ubuntus packages. I think Arch would be a good choise, because you can make a stable base with kernel and it's drivers and fresh, rolling software on top. And some kind of AUR repo so users could share their pkgbuilds. Why everyone sticks with Ubuntu? It's packaging is a nightmare! If I had a base Arch image with all tweaks, drivers and Qt recipies, that I can put into u-boot and emmc, it would be great, because I could write packages myself easily on top of it. pkgbuild is so simple. package and share pkgbuilds through AUR, isn't it great? and deb based distros are so outdated, so stuck in the 20 century.

Want an arch! :)
I have used T4 on android. Haven't tested it on lubuntu. After reading your review, I am going to install on it today. Would be great to read the FreindlyElec's developers reply on this.
I can't get Software Update to work with the Lubuntu OS install.
It fails immediately, and fails to update.
I tried re-downloading the latest Lubuntu eflash file, and re-installing. No change.
Clownfish wrote:
I can't get Software Update to work with the Lubuntu OS install.
It fails immediately, and fails to update.
I tried re-downloading the latest Lubuntu eflash file, and re-installing. No change.

Unfortunately all my attempts to make something fullfeatured and stable from it failed. Lubuntu build - is a horror by default, throw it away. Ubuntu core - OpenGL ES works only until you get upgrades or install anything. Ubuntu Desktop - the same, but it doesn't have gles examples preinstalled. They put libmali aside to the system, with hardcoded links, not ussing Debian's alternatives system, not packaged properly, to say to the system, that it allready provides egl and gles, everything related and their dev packages, so any update or install breaks glamour and gles support. Install sdl (which is used allmost anywhere) - and you left without gles.

They can't provide libmali sources by obvious reason, and they didn't provide their repository with prebuilt, proper, updated libmali which will tell to the system "don't use mesa, use me". So every move (I mean EVERY) breaks the system. The onlyway is to download and build EVERYTHING manualy. Maaan, why they choose ubuntu anyway? Even having Gentoo would be more userfriendly in this situation! I use Ubentu, but I can't install anything from it's repository because it breacks gles! This is so stupid!

Only thing is working somehow is video players, at least they work, mplayer, mpv, vlc, choose what you like. watch 1080p movies (they can't do more, because they work on cpu as I understand)
I am seeing the same things with Lubuntu. The more you try to update and upgrade the OS, the more it breaks. I find that I need to use the command line for almost anything I want to do. BTW: I was able to install Kodi and login with it as my desktop. It actually works pretty well except for things that are broken in the underlying OS.
I tried new version of friendlycore (20180905) and this time everything vent smoother. Package versions are more decent, so upgrade without breaking anything was possible.

First of all: before updating packages - put everything related to xserver, libxcb, libmali, libdrm, ffmpeg and gstreamer on "hold" (to prevent it's updates). It's a time consuming job, but it will save a lot of nerves, and time and everything. I didn't make a list of packages, next time will try to do it.

I do not waste my time anymore on LXDE or XFCE, they redraw windows very slow. KDE even on upgraded Qt5.11, from Ubuntu repo, without Rockchip patches and optimisations, it feels way better. And KDE's Neon project made recently a lot of work to make it run on Pine64 laptop. So I added Neon repository, And installed plasma-desktop. After I put necessary packages on "hold" everything vent smooth, but to install Dolphin file manager I had to sacrifice ffmpeg, because one of Neon's Qt libraries depends on libavcodec-extra (and something else), So I left without vdpau in ffmpeg, but switched VLC to xcb backend and I can watch at least 1080p movies without problem. By the way, Firefox can play 1080p as well. Glamour reports to be working, Friendlyelec's Qt examples are still running, Even after upgrade of all (unmasked) packages system is stable enough. Bravo devs :) Huge step forward.

Ok, now about SDL OpnGL ES and Mali drivers - SDL (and every opengl library and application) in Ubuntu repo is compiled against standard mesa, I had to get all libsdl2 source packages using "apt-get source" and recompile them with
export CC="-L/usr/rk3399-libs/lib64 -I/usr/rk3399-libs/include -I/usr/include"; debuild -b -uc -us
command. Don't know, it is right or not, but it is worked for me. Before that VICE emulator compiled with -sdlui2 segfaulted, and now it is running. Had no time to try something more serious, those experiments ate whole day. But the fact is - instead of just installing packages, I will need to recompile it against mali libs instead of mesa. And debians packaging system doesn't make my life easyer.

About packaging and upgrading - Unfortunately Friendlyelec does not provide some repo or ppa, where would be all Friendlyelec's needed packages with fresh version numbers (even dumb repackaging for changing only version number would help a lot). If I accidentally remove gstreamer, or drm, or any package provided by Friendlyelec. How do I put it back? search on github and compile? Need official repository or ppa, PLEASE!!!
I thought on buying this T4 but now after reading these comments, I might hold back.
I was thinking of buying and doing dual boot of desktop os (Ubuntu/Lubuntu/etc) and Android, between SD card and emcc.
I also thinking of connecting ESP8266 to do the dual boot selection (set high/low on the BOOT switch).
victagayun wrote:
I thought on buying this T4 but now after reading these comments, I might hold back.
I was thinking of buying and doing dual boot of desktop os (Ubuntu/Lubuntu/etc) and Android, between SD card and emcc.
I also thinking of connecting ESP8266 to do the dual boot selection (set high/low on the BOOT switch).

Note that Konstantin has overall unrealistic expectations and is mixing things a bit. It all depends on the perspective and to whom you are comparing too.

T4 is a very good hardware but software needs to get matured. That takes some time. To get a better picture, start reading here:

https://forum.armbian.com/topic/7498-nanopc-t4 (review)
https://twitter.com/armbian/status/1043228923818139650 (quick test)
https://github.com/ThomasKaiser/sbc-ben ... Results.md (comparison)

You will also find his complains there :)
igorp wrote:
Note that Konstantin has overall unrealistic expectations

I had a Raspberry Pi. I could run browser, a few games. A bit slow in all aspects, but fully working machine, can live with it, while keeping in mind that it is primarily a devboard. When I bought NanoPC my expectations were:
I buy SBC more powerful as a PC. Browsing and games should run faster (because of more powerfull CPU and GPU 50% more powerful as they were saying on product page) Less USB bottleneks and still it is tiny and I still get GPIO's. You call this unrealistic? What should I expect then?

What I really got is a beautiful, powerful peace of hardware and the nightmare on software side. Graphics speed directly on hdmi and thru internet via VNC are the same. Damn slow. Slower than Raspberry (which should be contrary). Games can't run at all, Almost none of them, only supertux is running as in slow motion movie. Upgrades are breaking GPU support even more, because developers are providing system as is, no official updates repository, naked Ubuntu, not optimized for anything.. Kernel and it's modules are built with minimum capabilities. Inaccessible directly, you have to crosscompile it and flash kernel from pc, hoping that it will not wipe anything. So even if you want to load or build additional driver for diy stuff - you will suffer.

Armbian has a more adequate structure, and potential, but it doesn't have GPU's drivers, etc. Playing videos hangs system after 2-3 minutes of using it.

I get half of Raspberry functionalities for 3 times (4 including taxes) higher price. Was I so unrealistic? Hell yes! This board is for benchmarking only. I'm done.
konstantin wrote:
I had a Raspberry Pi.

One of the main reasons why we don't provide Armbian for Raspberry Pi is because we don't want to do anything with their typical user base. RPi is a toy and you have no real use case.

Hardware makers have more troubles and have to live with this.
Hunzala wrote:
I have used T4 on android. Haven't tested it on lubuntu. After reading your review, I am going to install on it today. Would be great to read the FreindlyElec's developers reply on this.

How is the Android performance? Running 4K and able to play movies?

Who is online

In total there are 4 users online :: 0 registered, 0 hidden and 4 guests (based on users active over the past 5 minutes)
Most users ever online was 5185 on Wed Jan 22, 2020 1:44 pm

Users browsing this forum: No registered users and 4 guests