Power & Source of Big Ideas

NanoPi-M4 No HDMI Video Output

Moderators: chensy, FATechsupport

Hello,

I bought a 4GB NanoPi-M4 this November and after setting it up. Heatsink, antennas, HDMI cable to TV and microSD card flashed with either:

rk3399-sd-lubuntu-desktop-xenial-4.4-armhf-20181112.img
rk3399-sd-friendlydesktop-bionic-4.4-arm64-20181112.img
Armbian_5.59_Nanopim4_Ubuntu_bionic_default_4.4.152_desktop.img

using the provided win32diskimager and also Balena Etcher. I get the red light on and the green light flashing but no video output at all with any of the listed OSs. I wiggled the HDMI cable and even switched to a different one. No video.

I'm I missing something???

Thanks,
I too am experiencing this issue, however for me the green light flashed once, briefly and not again. I have tried flashing an SD card as well as an eMMC (and yes, is connected correctly).
Well, this is what happened:

For some reason the TV I was attaching the NanoPi-M4 was doing a weird overscan and dismissing the video signal entirely. Eventually after changing to a PC monitor, it started working normally.

I haven't had issues since.

Thanks,
I've tried other display devices, my issue persists.
I have the same problem but with NanoPC-T4.
Video was working well with all my TVs (LG, Samsung, Sony) until next reboot.
So, after regular reboot neither of TVs display anything.

However every of them detects HDMI connection when I boot NanoPC and if I do xrandr
then it prints

Code: Select all

$ xrandr
Screen 0: minimum 320 x 200, current 640 x 480, maximum 8192 x 8192
eDP-1 disconnected primary (normal left inverted right x axis y axis)
HDMI-1 connected 640x480+0+0 (normal left inverted right x axis y axis) 160mm x 90mm
   1920x1080     60.00 +  50.00    59.94    30.00    25.00    24.00    29.97    23.98 
   1920x1080i    60.00    50.00    59.94 
   1600x1200     60.00 
   1680x1050     59.88 
   1280x1024     75.02    60.02 
   1440x900      74.98    59.90 
   1280x960      60.00 
   1360x768      60.02 
   1280x800      59.91 
   1152x864      75.00 
   1280x720      60.00    50.00    59.94 
   1024x768      75.03    70.07    60.00 
   832x624       74.55 
   800x600       72.19    75.00    60.32 
   720x576       50.00 
   720x480       60.00    59.94 
   640x480       75.00*   72.81    66.67    60.00    59.94 
   720x400       70.08 
DP-1 disconnected (normal left inverted right x axis y axis)

(I can only see this output if I call "xrandr > ~/1" and then read file ~/1 via ssh).
So HDMI connection looks well, but the screen is black..


How can I reanimate HDMI? :|
Still need help..

Who is online

In total there are 2 users online :: 0 registered, 0 hidden and 2 guests (based on users active over the past 5 minutes)
Most users ever online was 106 on Tue Jun 04, 2019 5:48 pm

Users browsing this forum: No registered users and 2 guests