Hi everybody,

I am currently facing some struggles with the nanoPC-T4 recently bought to run armbian. When I got the board, I was able to run android default installed OS, but also armbian from a SD card.
But along the way, I decided to install armbian on an NVMe SSD memory to prevent running the OS from the SD card, anyway ... That when I started playing to with the kernel build, u-boot, flashing the emmc etc ..
I tried couple of times using the rockchip tool : developtool in MASKROM to play with the EMMC because I couldn't boot from the SD card, and wanted to start with a clean emmc, but every time the tool had to execute a libusb_bulk_transfer, a timeout was returned.
So I gave up debugging the board using usb, and started using the UART bus, which took me few days to get it work but finally was able to get the console ouput when starting the board.
I managed to play with the android CLI, but was still annoyed to not be able to boot up from the SD card, any os images provided by friendly arm. So I decided to make a radical step and clear the emmc with this command : sudo dd if=/dev/null of=/dev/mmcblkxxx,
this solution worked by clearing the memory and works so well that I cannot debug my board anymore. When I start the board in BOOT mode or not, the UART debug mode doesn't work as no console output is returned to my host.
When I try debugging by usb, I can see the device is alive, but a bulk_transfer return nothing else than an error. Here below is described the additional debug done on the USB.
However, I am now stuck and don't know what I can do more, to get the board working again. Does anyone have any idea ? Does anyone get difficulty using the USB bus to debug their board ?

Best regards,