Power & Source of Big Ideas

nano pi m4 v2 debug uart issue

Moderators: chensy, FATechsupport

I have recently received a nano pi m4 v2 device. Along with that I have also bought a 32 GB emmc module.
However when I tried to check the board booting , using debug uart port, I see board booting, as below
1. red led lights up
2, green led starts blinking
3. uart (115200 bps) shows garbage

I tried all kind of baud rates but unable to get any thing.
Kindly help.
Hi mrigendra,

I had the same issue like you. I tried to use balbes-150 Libreelec image for the NanoPi M4V2 (see topic RK3399 Libreelec) and had to connect to the UART console as well, because the image is not working. I did a lot of tests and the only thing that worked for me was using macOS as host system and connect to the console via picocom (tested with Armbian on an eMMC Module, screen and minicom didn't work):

picocom -b 1500000 /dev/tty.SLAB_USBtoUART --log d

So first install picocom on macos (on linux systems it's even easier):


Then connect your USB to serial adapter. In terminal enter

Code: Select all

ls /dev/tty.*
to get to know, how your adapter is called. If it doesn't find your adapter, you have to install the drivers first. Check, which chip you have and download and install the drivers. Then you should be ready to go. And yes, the baudrate is 1500000, which is the reason, why I was not able to connect to the console under Windows using Putty.

Hope this helps you and good luck!
mrigendra wrote:
3. uart (115200 bps) shows garbage

This generally happens when you don't have a ground connection. Double check for this.

It should be 115200, 8, NONE, 1
I'm having the same issue, even after following advice above.

Same platform, Nano pi M4 v2

debug pin1 gnd 0v to serial pin 5 ground
debug pin2 5v no connection
debug pin3 tx to serial pin 2 rx
debug pin4 rx to serial pin 3 tx


Nano pi spec says 3V level signals, pl2303 is 3.3. Perhaps the usb to serial adaptor has a 3.3v to 5v converter after the pl2303? So maybe I need a level shifter?

Code: Select all

usb 1-1: pl2303 converter now attached to ttyUSB0

Code: Select all

lsusb -v -d 067b:2303
Bus 001 Device 008: ID 067b:2303 Prolific Technology, Inc. PL2303 Serial Port

Code: Select all

picocom -b 1500000 /dev/ttyUSB0 --log picocom.log

Any pointers?
Hi, did you manage to fix the problem?
The M4 I think is the same baud rate as the T4 which is 1,500,000 so use something like Putty to connect to the debug port.

I got caught out with this same thing too.

Who is online

In total there are 4 users online :: 0 registered, 0 hidden and 4 guests (based on users active over the past 5 minutes)
Most users ever online was 5185 on Wed Jan 22, 2020 1:44 pm

Users browsing this forum: No registered users and 4 guests