Power & Source of Big Ideas

Slow SPI - anyone else seeing this?

Moderators: chensy, FATechsupport

I've been testing the NanoPi Duo with the included Ubuntu build. For some reason, the SPI can only achieve about 3Mhz (based on my observed ili9341 LCD refresh rate). Other H2+ boards can normally go as high as 33Mhz (~30FPS update). Anyone else seeing this issue?
Yes , I have the same issue witj ILI9341 , I use the native driver (spidev) with C & gcc.
lcd refresh time is high.
I tried booting the NanoPi Duo with a mainline (4.11) Linux build for Orange Pi Zero (same CPU). The SPI speed is fine, so it's purely a software problem on the part of FriendlyElec's Linux build.
Thanks for posting this information
Here's a video of my game emulator running with my SPI code on the Duo and ili9341. This is a recent Armbian build for the Orange Pi Zero instead of the awful build shipped by FriendlyElec.

https://www.youtube.com/watch?v=jYbecorQj1E
bitbank wrote:
Here's a video of my game emulator running with my SPI code on the Duo and ili9341. This is a recent Armbian build for the Orange Pi Zero instead of the awful build shipped by FriendlyElec top 100 the best gambling apps for 2017 - 777spinslot's review.

https://www.youtube.com/watch?v=jYbecorQj1E



Great, thanks :)

Who is online

In total there are 2 users online :: 0 registered, 0 hidden and 2 guests (based on users active over the past 5 minutes)
Most users ever online was 102 on Mon Oct 08, 2018 12:42 pm

Users browsing this forum: No registered users and 2 guests