I'm not able to use serial from naniopi neo plus 2. I was trying with minicom or python serial, however none of these works.
I connected SIM 908 shield which is working with arduino (tested). I'm trying to send just "AT" command and shield should reply with "OK". However it seems i have issue with UART on nanopi.

I was trying even minicom, just to test serial, however it seems not even this is working. According to dmesg i have in system /dev/ttyS[0,1,3]
[ 0.324096] 1c28000.serial: ttyS0 at MMIO 0x1c28000 (irq = 29, base_baud = 1500000) is a U6_16550A
[ 1.088544] 1c28400.serial: ttyS1 at MMIO 0x1c28400 (irq = 30, base_baud = 1500000) is a U6_16550A
[ 1.118006] 1c28c00.serial: ttyS3 at MMIO 0x1c28c00 (irq = 31, base_baud = 1500000) is a U6_16550A

currently I'm using pins 8,10 (UART 1) as Tx, Rx, but i tried also UART 2 with pins 11,22 (Tx, Rx). However non of these works. From outut of gpio readall, i see these pins are in mode (alt 4,alt 5). Im not sure if this is root cause and how can be pins changed.

Here is some more info:

Ubuntu version:
root@NanoPi-NEO-Plus2:~# cat /etc/os-release
VERSION="16.04.3 LTS (Xenial Xerus)"
PRETTY_NAME="Ubuntu 16.04.3 LTS"

cpu_freq output:
root@NanoPi-NEO-Plus2:~# cpu_freq
INFO: HARDWARE=Allwinnersun50iw2Family
CPU0 online=1 temp=39974 governor=ondemand cur_freq=120000
CPU1 online=1 temp=39974 governor=ondemand cur_freq=120000
CPU2 online=1 temp=39974 governor=ondemand cur_freq=120000
CPU3 online=1 temp=39974 governor=ondemand cur_freq=120000

thank you for help
Br palo