Power & Source of Big Ideas

Linux Mate Image with many issues - not usable

Moderators: chensy, FATechsupport

Hi ,
I just wanted to drop some lines here to summarize my first experiences with the NanoPi and it's Linux Mate Image.

1.) When logging in as root, a error window comes up with the error message: "mesg sttyname failed: inappropriate ioctl for device...."
2.) Mouse is not recognized upon bootup - needs to be removed and attached again.
3.) Several "Fatal error messages" indicating to "usr/bin/marco"
4.) NanoPi does not correctly turn off - always reboots
5.) NanoPi can't get out of suspend mode,.
6.) Mozilla browser does not start or always crashes after start

but the worst problems of all:

7.) It is not possible to change the monitor resolution of the default 1280x720@60Hz. Fortunately a colleague had a monitor supporting this setup, but I was not able to change it with cvt/xrandr & other commands, because it is absolutely unknown, what the name of the video device is (hdmi0 or hdmi1..)

Summary:
As per now - the NanoPi is a piece of dead hardware - as the Linux Mate image is just not useable. I am very disappointed.

Regards, Klaus
Hi,

I am sorry we have no much time developpoing Ubuntu Mate. we recommend Ubuntu Core for the NanoPi A64 board. Or you can find other open source community about Allwinner A64

Thank you

-- Mindee
I have experienced some, but not all, of the problems described in the first post.

@Mindee: I urge Friendly Arm to do a better job developing the Ubuntu-MATE operating system for the A64. This is an excellent alternative to the Raspberry Pi 3, but Ubuntu-CORE will not work for many people. Supplying the OS with a browser (Firefox) that immediately crashes each time it is launched is pretty embarrassing for your company! If you do not do a better job supporting your (current) products then why would I come back and buy any future products from Friendly Arm???

-Charlie
charlielaub wrote:
I have experienced some, but not all, of the problems described in the first post.

@Mindee: I urge Friendly Arm to do a better job developing the Ubuntu-MATE operating system for the A64. This is an excellent alternative to the Raspberry Pi 3, but Ubuntu-CORE will not work for many people. Supplying the OS with a browser (Firefox) that immediately crashes each time it is launched is pretty embarrassing for your company! If you do not do a better job supporting your (current) products then why would I come back and buy any future products from Friendly Arm???

-Charlie



Hi, Charlie

We can't get enough resource from Allwinner, no better chip price, no engineer helping us, we have tried our best on this NanoPi A64 board for now. We provided the Ubuntu Core, which can help you to check/test most of the hardware on the board. Please understand.


Thank you

-- Mindee
[quote]Hi ,
I just wanted to drop some lines here to summarize my first experiences with the NanoPi and it's Linux Mate Image.

1.) When logging in as root, a error window comes up with the error message: "mesg sttyname failed: inappropriate ioctl for device...."
2.) Mouse is not recognized upon bootup - needs to be removed and attached again.
3.) Several "Fatal error messages" indicating to "usr/bin/marco"
4.) NanoPi does not correctly turn off - always reboots
5.) NanoPi can't get out of suspend mode,.
6.) Mozilla browser does not start or always crashes after start

but the worst problems of all:

7.) It is not possible to change the monitor resolution of the default 1280x720@60Hz. Fortunately a colleague had a monitor supporting this setup, but I was not able to change it with cvt/xrandr & other commands, because it is absolutely unknown, what the name of the video device is (hdmi0 or hdmi1..)

Summary:
As per now - the NanoPi is a piece of dead hardware - as the Linux Mate image is just not useable. I am very disappointed.

Regards, Klaus[/quote]

You can check out this WiP (user effort) https://github.com/avafinger/nanopi-a64-firmware and see if works for you.
You can even install MATE over LXDE and later uninstall LXDE.

This is a dev image where you can extend it, a LEAN and MEAN image.
mozilla firefox question - always fails... First of all you must do upgrade to the next distrro. apt-get update apt-get dist-upgrade... you have 15.10 ubunbtu whcich is not supported yet. 16.04 is supported
Mindee wrote:
Hi,
I am sorry we have no much time developpoing Ubuntu Mate. we recommend Ubuntu Core for the NanoPi A64 board. Or you can find other open source community about Allwinner A64

wouldnt it be better to remove the Mate-Image? - because the sources for Ubuntu Wily Werewolf (15.10) arent available anymore:

Code: Select all

Err http://ppa.launchpad.net wily/main arm64 Packages
  404  Not Found
Err http://ports.ubuntu.com wily/main arm64 Packages
  404  Not Found [IP: 91.189.88.150 80]
E: Some index files failed to download. They have been ignored, or old ones used instead.


AND the version with Ubuntu Core is also ONLY Ubuntu Wily Werewolf (15.10) which cant be updated via normal apt :(
So - no working OS is available on your page :(
Do you know a working third party OS for the NanoPi A64?
Mindee wrote:
charlielaub wrote:
I have experienced some, but not all, of the problems described in the first post.

@Mindee: I urge Friendly Arm to do a better job developing the Ubuntu-MATE operating system for the A64. This is an excellent alternative to the Raspberry Pi 3, but Ubuntu-CORE will not work for many people. Supplying the OS with a browser (Firefox) that immediately crashes each time it is launched is pretty embarrassing for your company! If you do not do a better job supporting your (current) products then why would I come back and buy any future products from Friendly Arm???

-Charlie
https://phenq-reviews.com/uk/


Hi, Charlie

We can't get enough resource from Allwinner, no better chip price, no engineer helping us, we have tried our best on this NanoPi A64 board for now. We provided the Ubuntu Core, which can help you to check/test most of the hardware on the board. Please understand.


Thank you

-- Mindee


Terminate those who are not clearly be there for making things harder
Mindee wrote:
Hi,

I am sorry we have no much time developpoing Ubuntu Mate. we recommend Ubuntu Core for the NanoPi A64 board. Or you can find other open source community about Allwinner A64

Thank you

-- Mindee


Hi Mindee, you mentioned that you recomment Ubuntu core for the A64, can you please provide a link to the appropriate version, there are many options here:http://cdimage.ubuntu.com/ubuntu-core/18/stable/current/?_ga=2.159072250.1171262717.1555414184-1338167324.1555414184
I only know the "old" FriendlyCore image at
https://drive.google.com/open?id=1n73b3 ... X8TZ6RTcBN

or Ubuntu from the user avafinger
https://github.com/avafinger/nanopi-a64-firmware

or as experiment a "headless"/server-version of a actual armbian ;)
https://forum.armbian.com/topic/9308-ex ... anopi-a64/

Code: Select all

Welcome to ARMBIAN 5.78 user-built Debian GNU/Linux 9 (stretch) 5.0.7-sunxi64
package bsp-kernel[5.78] u-boot[5.78] dtb[5.78] firmware[5.77] config[5.78]

Linux npi-a64 5.0.7-sunxi64 #5.78 SMP Wed Apr 10 09:20:27 +03 2019 aarch64 GNU/Linux

Who is online

In total there are 2 users online :: 0 registered, 0 hidden and 2 guests (based on users active over the past 5 minutes)
Most users ever online was 2865 on Sun Nov 10, 2019 5:27 am

Users browsing this forum: No registered users and 2 guests