Power & Source of Big Ideas

Ubuntu 16.04 Xenial with LXDE-Desktop for NanoPi A64

Moderators: chensy, FATechsupport

Today I did get my NanoPi A64 - but both Ubuntu-Images at the FriendlyARM page
are only Ubuntu 15.10 Wily Werewolf Images (Mate and QT-Core) where the sources
for updateing via apt arent available anymore (Error 404) :(

So I did serach for another OS for the NanoPi A64....

armbian nor DietPi not available for the NanoPi A64 and also not debian :(

BUT I did found something that does make a useable board out of the NanoPi A64 :)

Here at this Page you could find a Ubuntu 16.04 xenial with LXDE-Desktop:
https://github.com/avafinger/nanopi-a64-firmware

The only thing with that is that creating the bootable MicroSD-Card is a little bit dificult,
but the instructions in the bottom of the page are quite well :)

You need a Linux-System for creating the Boot-Card - so I did use my second NanoPi = the NEO2
with a single-slot MicroSD-Card Reader/Writer.

After inserting the MicroSD-Reader/Writer the dmesg did show me the MicroSD-Card as /dev/sda -
so I had to use /dev/sda and not /dev/sdc for the formating and flashing commands.

Code: Select all

root@Neo2:/home/guido/nanopi-a64-firmware# ./format_sd.sh /dev/sda
root@Neo2:/home/guido/nanopi-a64-firmware# ./flash_sd.sh /dev/sda


I also switched from 1080p to 720p

Code: Select all

cd /media/ubuntu/boot/a64
cp a64-2GB.dtb a64-2GB.dtb_1080p
cp a64-2GB.dtb_720P a64-2GB.dtb a64
reboot


Now my NanoPi A64 is updateing the xenial via apt (170MB to go)....

Code: Select all

Welcome to Ubuntu 16.04.3 LTS (GNU/Linux 3.10.105 aarch64)
Linux nanopi-a64 3.10.105 #1 SMP PREEMPT Mon Mar 27 10:59:50 BRT 2017 aarch64 aarch64 aarch64 GNU/Linux
[quote="Hannes Worst"]Thank you, Guidol, for pointing us out to this image. For what it's worth, it works more or less for me. There are some issues with my hdmi-vga transformer however. Sometimes uit connects well to my monitor at one time, while the next time I get no screen whatsoever. I can see it is not related to u-boot, but after the boot my monitor goes often into sleeping mode - receives no signal.[/quote]

Many HDMI to VGA converter are known not to work properly with some monitor/resolution.
If you really want to know if the issue is your converter, just plug to some HDMI monitor without any adapter if possible.

Also check your PSU, HDMI draws a lot power. Sometimes in rare occasions the u-boot enters into the shell, that happens with Pine64 also.

You can attach a TTL serial debug and see the boot log, this would helps a lot.
@lex. Thank you for your reply. I'm afraid the monitor goes black -in sleeping mode- after it is turned on for a short while by u-boot, which is triggered in my opinion by a kernelpanic. My usb-keyboard is also rendered unresponsive after this. But it's a wild guess ofcourse. I don't have a HDMI-monitor unfortunately. I need to get a serial cable so I will be able view what is going on and what not. I will order one, as soon I have more info I will report back. But the Ubuntu operating system is really very usable, I use it on a daily basis. The problems occur only once in a while!

Who is online

In total there is 1 user online :: 0 registered, 0 hidden and 1 guest (based on users active over the past 5 minutes)
Most users ever online was 42 on Fri Jul 15, 2016 1:04 am

Users browsing this forum: No registered users and 1 guest