Power & Source of Big Ideas

NEO2 Ubuntu Static IP not working

Moderators: chensy, FATechsupport

Running a NEO2 with a NAS DOC on Ubuntu Xenial.
I have tried several ways to configure Static IP address and it looses all connectivity to eth0 and need to enter system via the serial port.

Is there a different approach to:

sudo nano /etc/network/interfaces

auto eth0
iface eth0 inet static
All I can suggest is looking at the RaspberryPi forums. There is discussion about setting up static IPs which I think involved changing dhcpd,conf

Good luck!
I tried this once and failed, so I searched some more without any luck. Went back to ModMyPi.
So I tried again by editing the dhcpcd.conf file, that did not exist in /etc

sudo nano /etc/dhcpcd.conf

And added:
nohook lookup-hostname
interface eth0

static ip_address=
static routers=
static domain_name_servers=

press ctrl+x to exit, “Y” to save, reboot and ifconfig and it worked!!!


Who is online

In total there is 1 user online :: 0 registered, 0 hidden and 1 guest (based on users active over the past 5 minutes)
Most users ever online was 102 on Mon Oct 08, 2018 12:42 pm

Users browsing this forum: No registered users and 1 guest