Power & Source of Big Ideas

tun/tap driver

Moderators: chensy, FATechsupport


it seems like tuntap driver is missing on ubuntu build. Is it possible to install it somehow?

It's not working properly, and because of that I can't set a vpn interface in the network parameters, here's what I have tried:

root@NanoPi-NEO:~# ls /dev/net/tun

root@NanoPi-NEO:~# sudo modprobe tun
FATAL: Module tun not found in in directory /lib/modules/4.11.2

root@NanoPi-NEO:~# sudo mknod /dev/net/tun c 10 200
mknod: /dev/net/tun: File exists

root@NanoPi-NEO:~#chmod 600 /dev/net/tun

root@NanoPi-NEO:~#sudo modprobe tun
FATAL: Module tun not found.

root@NanoPi-NEO:~#cat /dev/net/tun
cat: /dev/net/tun: No such device

Tried going to /usr/src/kernel and run make menuconfig; /usr/src was empty!

So I tried reinstalling the source code for the Linux kernel:
*Downloaded it from https://www.kernel.org/ (version 4.12.8)
*Configured it with:
root@NanoPi-NEO:~#make menuconfig
(where mind you, I couldn't switch the "TUN/TAP Universal driver" option On with "Y")
*Started building:
The steps (from what I understood) to build the kernel and install it are:
root@NanoPi-NEO:~#make (builds the kernel)
root@NanoPi-NEO:~#make modules (builds the kernel modules) (This is where I got an error)
root@NanoPi-NEO:~#make modules_install (install the built modules)
root@NanoPi-NEO:~#make install (installs the built kernel)

after lots of bugs and corrections, at the second one (make modules) I got this error:
WARNING: could not open /var/tmp/mkinitramfs_c9kIr7/lib/modules/4.12.8/modules.builtin: No such file or directory

and at this point it got too frustrating, I'm not knowledgeable with the kernel and I found contradictory informations all over the web, so please, please, please, can you find a fix?
We made simple but powerful tools to remake kernel on your desktop machine.

https://docs.armbian.com/Developer-Guid ... eparation/

Most FriendlyElec boards are supported.

Modern kernel, which you are trying to use is still under developing ... you can enable compilation only with EXPERT="YES" ... and at kernel compilation, you will be prompted to change the default configuration. Choose it and add/change whatever you need.

If you use our pre build images, out of the tree module compilation is possible - not sure if it will work for this case - since we supply headers and toolchain by default.

BTW. With strictly mainline kernel from http://www.kernel.org there is only very basic support.

Who is online

In total there are 2 users online :: 0 registered, 0 hidden and 2 guests (based on users active over the past 5 minutes)
Most users ever online was 5185 on Wed Jan 22, 2020 1:44 pm

Users browsing this forum: No registered users and 2 guests