Power & Source of Big Ideas

Can a Desktop enviroment be installed

Moderators: chensy, FATechsupport

I have an app that I would like to use on the NanoPi NEO that can only be used from a GUI desktop.
I have installed tightvncserver, and can connecto to it but its a blank screen.
I then installed xorg, and gdm, now i get a terminal window when I remote in with VNC.
Seems like I am getting close, but I want an actual desktop environment like on other Friendly Arm boards.

Anyone know what I need to do to get it ?
SInce NEO doesn't have any video interface (LCD or HDMI) we didn't put our resources on migrating an OS with GUI (e.g Android and Debian) to NEO.

For M1 which is also H3 based but has an HDMI interface we have Debian and Android images available
I understand, but is't there a way I can apt-get install things to get a desktop which I can either use Remote Desktop Connection or VNC to get to it ?
For anyone else who wants a desktop to log into to run apps, all I did was this and works great.

#1) apt-get install xubuntu-desktop
#2) apt-get install xrdp

reboot and do startx &

then on your PC run Remote Desktop Connection and enter in the IP address of your device.

that sounds really interesting!

But how did you make the apt-get installs work on NanoPi Neo?

Even after "apt-get update" and "apt-get upgrade" both packages you describe cannot be installed for my Neo.
And apt-cache search does not show them as installable:
root@FriendlyARM:~# apt-cache search xubuntu-desktop
root@FriendlyARM:~# apt-cache search xrdp

Which packages did you install before you were able to install these two packages?

I did install "nanopi-neo-core-qte-sd4g-20160704.img", did you install something else?

I had to open
nano /etc/apt/sources.list

and uncomment these 2 line, then do another apt-get update.
deb http://ports.ubuntu.com/ubuntu-ports/ wily universe multiverse
deb-src http://ports.ubuntu.com/ubuntu-ports/ wily universe

You did say nothing on install time for "apt-get install xubuntu-desktop" -- for me it was 3 hours!

Code: Select all

root@FriendlyARM:~# time ( apt-get install xubuntu-desktop )
aspell-autobuildhash: processing: en [en_US-wo_accents-only].

real   182m59.774s
user   13m41.560s
sys   17m39.150s

I did not install "xrdp" like you did [no Windows! ... ;-) ] but "tightvncserver".

"startx" immediately worked, and starting "vncserver" worked as well.
Firefox web browser is installed, but running firefox process that wants 550MB on my 256MB NanoPi Neo resulted in 100% CPU for "kswapd0" process ;-)

Thanks again for this information,
  • on how to install and run XServer on Neo without GPU and HDMI
  • on how to open the "apt-get install" cage


Even epiphany-browser does need 340MB memory, not nice for 256MB NanoPi Neo ;-)

Who is online

In total there are 9 users online :: 0 registered, 0 hidden and 9 guests (based on users active over the past 5 minutes)
Most users ever online was 5185 on Wed Jan 22, 2020 1:44 pm

Users browsing this forum: No registered users and 9 guests