Power & Source of Big Ideas

Problem connecting M1 plus to internet via ethernet

Moderators: chensy, FATechsupport

Hi,

I'm having trouble connecting my nanoPi M1 plus to the internet via ethernet cable.

I'm running debian with the image
nanopi-m1_debian-jessie_3.4.39_20170531.img
from
https://www.mediafire.com/folder/3q2911 ... 3df73c6dk6

Output of ifconfig etc below;

Code: Select all

fa@FriendlyELEC:~$ sudo ifconfig
[sudo] password for fa:
eth0      Link encap:Ethernet  HWaddr 4e:90:ff:e1:1d:e4 
          inet6 addr: fe80::4c90:ffff:fee1:1de4/64 Scope:Link
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:4 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:580 (580.0 B)
          Interrupt:114

lo        Link encap:Local Loopback 
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:1 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:112 (112.0 B)  TX bytes:112 (112.0 B)


fa@FriendlyELEC:~$ cat /etc/network/interfaces
# interfaces(5) file used by ifup(8) and ifdown(8)
# Include files from /etc/network/interfaces.d:
source-directory /etc/network/interfaces.d

allow-hotplug eth0
   iface eth0 inet dhcp

allow-hotplug wlan0
iface wlan0 inet dhcp
        wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf



It's my first time setting up a pi-like device so assume I've made mistakes :)
Just realised I have the wrong image!

Will check the proper one (m1 plus).

Who is online

In total there are 3 users online :: 0 registered, 0 hidden and 3 guests (based on users active over the past 5 minutes)
Most users ever online was 42 on Fri Jul 15, 2016 1:04 am

Users browsing this forum: No registered users and 3 guests