Power & Source of Big Ideas

Device /dev/ttyUSB0 is missing (Nanopi Neo)

Moderators: chensy, FATechsupport

Hello. i get no /dev/ttyUSB0 which i want to use in node-red.

I use this image
http://wiki.friendlyarm.com/wiki/index. ... Image_Card
(Ubuntu core 16.04)

I have no idea, can anybody help me?

~$ lsusb
Bus 008 Device 008: ID 0403:6001 Future Technology Devices International, Ltd FT232 USB-Serial (UART) IC

~$ cat /proc/version
Linux version 4.11.2 (root@wwd) (gcc version 4.9.3 (ctng-1.21.0-229g-FA) ) #19 SMP Sat May 27 10:23:19 CST 2017

Note: With my tests with Jessy lite (DietPI) it works perfekt.

Thank you!
I have the same problem,

In my case:

Code: Select all

lsusb
...
Bus 007 Device 002: ID 0403:6015 Future Technology Devices International, Ltd Bridge(I2C/SPI/UART/FIFO)
...


and

Code: Select all

$ uname -r
4.11.2


One clue could be that i could not find the library ftdi_sio

Code: Select all

modprobe ftdi_sio
modprobe: FATAL: Module ftdi_sio not found in directory /lib/modules/4.11.2


In some forums i found that it could be solved by installing

Code: Select all

sudo apt-get install linux-image-extra-virtual


but could not find that package.
Upbumping this topic as I too can't communicate with ttyUSB0 on nanoPi Neo. I am using the same ubuntu image as you guys (The one the pamphlet recommends that comes with the NEO)
It looks like the new kernel 4.x does not include anymore a lot of drivers that were previously included by default. The FTDI USB-Serial is one of them (ftdi_sio).

I've tried to download the sources and compile the drivers but when running (

Code: Select all

make menuconfig
the option for the USB Serial drivers are also gone now. So I'm kind of stuck with the old kernel for the time.

I would also be interested if someone finds a way to install the drivers in the 4.x kernel.

Who is online

In total there are 10 users online :: 0 registered, 0 hidden and 10 guests (based on users active over the past 5 minutes)
Most users ever online was 5185 on Wed Jan 22, 2020 1:44 pm

Users browsing this forum: No registered users and 10 guests