Hi Guys

I am complete noob in these things, but I recently got my self a Nano Pi Neo2 kit wit a Display on it. ( It is this one: https://www.antratek.nl/neo2-512mb-comp ... gLM-_D_BwE)

I set It up with Armbian and Pi-Hole and It worked fine for 30 minutes. Then de Neo2 Failed. I sent It back to the seller, and they say they have repaired It by replacing the board. Only thing is the new board is not coming online in the network. It is simply not showing up in my ARP or DHCP tables. I tried a lot of different images and SD cards, and different powersupplies. But the board is nog getting into the network.

Whatever Image I choose, the board does power up, and the NIC leds start blinking, but never I see that a DHCP lease was issued.

I contacted the reseller again, and he says the board was replaced and working OK with these OS images.(http://wiki.friendlyarm.com/wiki/index.php/NanoHat_OLED ) And they say I now should post my problem into this forum . (So here I am). I tried every image on that link, but the NIC is not getting online.

Hope you guys can shed some light into this. ( I personally thing Antratek simply did not replace the board, allthough they said they did).

Kind regards