Power & Source of Big Ideas

NanoPI M1 Plus with Enterprise WiFi?

Moderators: chensy, FATechsupport

I spend 250-300 nights each year in hotels which only have "Enterprise WiFi" (i.e., WiFi where you need to enter your Room Number or check a box before you can access the Internet). I have successfully used RPI, BPI and OPI boards with onboard WiFI or USB WiFi in a number of locations - with no configuration of the OS parameters needed. When the OS boots and I open a browser, I can access the Enterprise "login" screen and enter the credentials.

I just purchased a NanoPI M1 Plus, which came with antenna, which I installed. I installed Debian from your Downloads and board boots properly. However, I do not seem to get the board to receive any RF for the WiFi--no signals are shown. All of my other single board computers work properly in this hardware setup in this hotel room. (Connected with 5V, 3000mA power supply)

Is it necessary to configure Linux to allow the radio to work at all? I understand if the desire is for autoWiFi to a personal secure router, but I am not even at the point of being able to do handshaking to the router.

I am very interested in evaluation of this board for recommendation to a Linux User Group, but at this point I can do nothing.

I would sincerely appreciate it if someone could offer me some suggestions for getting the WiFi radio to sense an RF signal (which is quite strong).

Thanks!

Larry
Larry,

Most of the models I have played with are in AP mode. Have you turned that off?

Dave
Hi Dave,

No, I wasn't aware of this initial configuration. How is that change accomplished?

I guess that the designer assumes that you have an Ethernet connection available at startup, so the AP setting would then work. If all you have is WiFi, then you have another level of complexity. Nothing of this sort was obvious in the "Start Up" on their WiKi.

Having worked with several other SBCs with WiFi onboard, as well as those which require a WiFi dongle, this is the first time that I have encountered a "disabled" WiFi on initial boot. (Usually the first thing that you want to do when you start a board for the first time is to update the OS.)

I look forward to you pointing me in the right direction for the "AP" configuration reversal.

Thanks!

Larry
Try:

turn-wifi-into-apmode no

I haven't read the Wiki page on your device but many of the other models behave like this.
Oops, I see it is not mentioned on the M1 Plus wiki page. Maybe the OS for the AllWinner parts are set up differently?

What do you get with:

ifconfig
wpa_cli -iwlan0 scan_result
Hi Dave,

I will try this tonight and report.

I did cat /sys/module/bcmdhd/parameters/op_mode and there is no bcmhd module...

I tried turn-wifi-into-apmode no and it reported that the command was no found.

It should not be this difficult...

I might just take it home and donate it to a Linux Users Group.

Larry
Are you running the Debian image?

5.4 Wireless Connection I assume you have setup the wpa_supplicant.conf file.
Hi Dave,

I had tried Debian with no WiFi success and currently have Ubuntu MATE as the OS. With neither system have I seen any WiFi awareness. I will plug in the Debian microSD card tonight and see if that works.

When I do ifconfig -a I see no Wireless entry.

I have not set up "supplicant" as I am not trying to connect with a specific router. I would like to be able to see what RF sources the board senses and then choose (as with a smartphone). Unfortunately this board reports nothing.

I will try further this week and then the board will go to the donate box, if I see no WiFi reported.

I have Omega board, RPI and Orange PI all sitting on my desk and their OS connecting to the hotel Enterprise WiFi. NO special configuration was required to cause the WiFi radios to see 2.4GHz signals around them. My iPhone set to WiFi does not see a NanoPi signal, which suggests that either the board is not emitting 2.4GHz RF because of a setup issue or it is non-functional.

Since I have read that there are power dissipation issues with this cramped board, I suppose that it is possible that the WiFi is specifically disabled by the default OSs, since WiFi and BT are known to be power hogs.

My ultimate goal is to be able to recommend an inexpensive board to folks who would like to replace their desktop CPUs, by just retaining their monitor, keyboard and mouse and adding a power supply.

Unfortunately, at this point, unless my switch to Debian tonight produces a "WiFi sniffer", I will pull this board from a possible recommendation. I could not expect a current Windows user to be able to make this sort of adjustments to an OS configuration in order to transition to Linux... More and more users are going to a WiFi only environment--at the rate that updates/upgrades or software additions are needed for the average Linux user, a board than needs Ethernet access can sink to oblivion.

Thanks,

Larry
Larry,

wpa_cli -iwlan0 scan_result showed nothing. Maybe try iwlist scan

Have a look in /etc/rc.local and post the contents. I stop Bluetooth in here, maybe somebody stopped networking.
Hi Dave,

Done with it.

I wasted too much time trying to get this board to allow its radios to function.

In addition, I tried ethernet connection from home over the weekend and it was just as dead.

I really appreciate your time in trying to help me along!

I still have no idea whether the malfunction is:

1) Board uses too much power, so we disable radios

2) Dummy MAC address is an issue

3) WiFi, USB WiFI and Ethernet ALL need to be configured before they will work

4) The hardware has a malfunction

But in any case, the board is a waste of money no matter what extra features they have added if even the Wiki for the particular board does not give a path to allow "update" and "upgrade" without the need to dig into the innards to perform configuration.

I will give it a "do not buy" recommendation for the Linux User Group.

Take care,

Larry
The Ubuntu MATE OS you ended up at is probably not for the M1 plus, but just the M1. It installs but without radio functionality. I just went through this myself. Everything lists MATE as an M1 plus OS but its an error in the specs.
If its not too late for you the debian wifi can be established by entering TTY2 and editing (vi) the WPA_Supplicant.conf. I suspect this is not what you want to be doing every stop though.
That's the best I can assit, hope its helpful, if it's not too late.
supercj70 wrote:
The Ubuntu MATE OS you ended up at is probably not for the M1 plus, but just the M1. It installs but without radio functionality. I just went through this myself. Everything lists MATE as an M1 plus OS but its an error in the specs.
If its not too late for you the debian wifi can be established by entering TTY2 and editing (vi) the WPA_Supplicant.conf. I suspect this is not what you want to be doing every stop though.
That's the best I can assit, hope its helpful, if it's not too late.

Thanks dave ill have a lool tjrough that link, i think its def somethinf to do with the way the linker is working

Who is online

In total there are 5 users online :: 0 registered, 0 hidden and 5 guests (based on users active over the past 5 minutes)
Most users ever online was 2865 on Sun Nov 10, 2019 5:27 am

Users browsing this forum: No registered users and 5 guests