Power & Source of Big Ideas

NanoPi Neo2 Ethernet Speed dropping?

Moderators: chensy, FATechsupport

Hi there!

Would like to seek some help on the matter.

First, my setup details:
SBC : NanoPi Neo2 512MB, with Nanopi specified heatsink (NPiN2)
OS : DietPi v6.15 (upgraded from v6.12) in 8GB class10 microSD
PSU : 5V 3.0A, microUSB cable rated 2.4A
Network : Ethernet LAN connection using CAT6 cable, connected to gigabit Ethernet switch
USB HDD : 2.5" Seagate Barracuda 2TB in Orico SATA to USB3.0 HDD case, using JMicron Chipset

Code: Select all

 ───────────────────────────────────────
 DietPi     | 07:13 | Mon 17/09/18
 ───────────────────────────────────────
 v6.15      | NanoPi NEO 2 (aarch64)
 ───────────────────────────────────────
 eth0       | 192.168.110.11
root@DNanoPiNeo2:~# lsblk
NAME        MAJ:MIN RM  SIZE RO TYPE MOUNTPOINT
sda           8:0    0  1.8T  0 disk
└─sda1        8:1    0  1.8T  0 part /hdd
mmcblk0     179:0    0  7.5G  0 disk
├─mmcblk0p1 179:1    0  100M  0 part /boot
└─mmcblk0p2 179:2    0  7.1G  0 part /


The unit above is mainly used as NAS and torrent box, using Deluge client.

This unit is running together with another torrent box based on Raspberry Pi Model B+ rev 1.2 (c) 2014 (RPi1B+), running Raspbian stretch with desktop. Identical USB HDD used, connected to the same gigabit Ethernet Hub switch. Torrent client is also Deluge on this RPi1B+ with settings (preferences) an exact copy of the settings in NPiN2-DietPi setup (well...except for the download directories)

I was extremely happy when I first tested the NPiN2-DietPi download speed after the initial setup (back then it was v6.12). It was way faster than the RPi1B+ setup. It was really taking advantage of the Gigabit ethernet port.

Second: The problem
As both are running in parallel, I noticed that the download speeds on the Gigabit NPiN2-DietPi drops after sometime. making it slower than those on the 100Mbps RPi1B+. Even if I change the download order on the NPiN2-DietPi, the download speed remains slow (average 600~650kbps vs. average 1.0Mbps on RPi1B+).

Things tried to fix the problem:
First I thought that maybe the DietPi OS needs to be upgraded, so I did an upgrade from v6.12 to v6.15, but that did not fix the problem.
Also tried changing the LAN cable of the NPiN2 to thicker CAT6 rated cable, but no effect.
Also tried to connect the USB HDD to NPiN2 via powered USB2.0 hub, no effect.

As of now, the download race between NPiN2-DietPi vs RPi1B+ is always won by RPi1B+ (which is supposed to be much slower than NPiN2)

The question:
a. Are there any setting(s) that I need to modify to in order for the NPiN2-DiePi to maintain taking advantage of the Gigabit port?
b. Any pointers in order for the NPiN2-DietPi to regain download supremacy over RPi1B+?

Thanks!
Unofficially conceding defeat? :shock:

Maybe after 1 week and no replies to address the problem then I guess I can consider it to be official.... :(
LTolledo wrote:
Unofficially conceding defeat? :shock:

Maybe after 1 week and no replies to address the problem then I guess I can consider it to be official.... :(


FriendlyARM doesn't provide support for Dietpi. That is official - check the wiki.
OK I will try using your officially supported OS and see if things improve...
LTolledo wrote:
OK I will try using your officially supported OS and see if things improve...


Probably not since Dietpi is official image + BASH script.

This will work:
https://www.armbian.com/nanopi-neo-2
Thanks igorp for the link.

Will try using the recommended OS (armbian) on the nanopi neo 2 and see if it improves dramatically...
I am interested to know if you resolved this issue - and how.
Q

Who is online

In total there are 2 users online :: 0 registered, 0 hidden and 2 guests (based on users active over the past 5 minutes)
Most users ever online was 102 on Mon Oct 08, 2018 12:42 pm

Users browsing this forum: No registered users and 2 guests