Power & Source of Big Ideas

Neo2 with NanoHat Hub

Moderators: chensy, FATechsupport

Hi Everyone,

Anyone of you has tried to use NanoHat Hub with Neo2?

According to http://wiki.friendlyarm.com/wiki/index. ... O2/NEO_Air, it should be compatible, however, when I test "python ~/BakeBit/Software/Python/bakebit_led_blink.py", the LED doesn't blink.

Here is the info:
1. I have connected LED to D3
2. I have tried to reverse the direction of LED

But nothing ok.

Just wanna to make sure NanoHat Hub is compatible with Neo2.


I can confirm, there is also a problem with NeoPi and the NanoHat hub.

Out-of-the-box installation of the nanopi-neo_ubuntu-oled_4.14.52_20180628.img OS image.

Attaching the hub and the led of the NEO Project Super Starter Kit. Installing the SW according the WIKI. But the led test fails. Double checked everyting. In the next days I will try to pin down the problem step by step.
I have drafted an Email to the support, but seems no reply yet for the issue
I send also an e-mail two weeks ago to the support. But no answer.

I tried to flash the Hub again with the firmware. But this step fails with an error.

http://wiki.friendlyarm.com/wiki/index. ... an-20-2017

Code: Select all

avrdude: Device signature = 0x1e9516
avrdude: Expected signature for ATmega328P is 1E 95 0F
         Double check chip, or use -F to override this check

I am really disappointed from FA.
The NanoHat works now for me! But due the many steps yesterday, I am not sure what was the exact reason for the problem.

Yesterday I installed the newest image for the Nano Pi

Please re-check everything with the newest image. If the NanoHat is still not working.

http://wiki.friendlyarm.com/wiki/index. ... anoHat_Hub
Install avrdude and configurate the /etc/avrdude.conf according the description.

But updating the firmware fails at this point - the newest NanoHat uses a m328pb instead a m328p in the firmware update script.

Therefore add follwing part parent section in /etc/avrdude.conf for the 328pb
https://github.com/watterott/ATmega328P ... rdude.conf

Code: Select all

part parent "m328"
    id         = "m328p";
    desc      = "ATmega328P";
    signature      = 0x1e 0x95 0x0F;

    ocdrev              = 1;

part parent "m328"
    id         = "m328pb";
    desc      = "ATmega328PB";
    signature      = 0x1e 0x95 0x16;

    ocdrev              = 1;

The last step: modify the avrdude commands at the end of the file
~/BakeBit/Firmware# ./firmware_update.sh

Change m328p to m328pb.

Code: Select all

avrdude -c nanopineo -p m328pb -U lfuse:w:0xFF:m
avrdude -c nanopineo -p m328pb -U hfuse:w:0xDA:m
avrdude -c nanopineo -p m328pb -U efuse:w:0x05:m
avrdude -c nanopineo -p m328pb -U flash:w:bakebit_firmware.hex

Than start the update

Code: Select all

cd ~/BakeBit/Firmware 

Ignore a warning according a fuse. Thats all!
But be aware, a bad firmware update can kill a device.

with best regards
Hi Pezi,

Great to see your NanoHat Hub working, but I am not that lucky. When I update the firmware, it holds on the below:

avrdude: verifying ...
avrdude: verification error, first mismatch at byte 0x0000
0xf5 != 0x05
avrdude: verification error; content mismatch

avrdude: safemode: efuse changed! Was 5, and is now f5
Would you like this fuse to be changed back? [y/n] y

Do you have such problem? I have wait for hours, but it is still stopping at that screen.


At this point you must say no. Sorry for my in-complete description.

Hi Pezi,

It finally works, very much for your help. I finally can start playing with my toy.

PS. Seems that the support from FE a bit poor this time.

Hi Kenneth!

My theory - the hub was sent without any firmware. Due the hardware change of the chip on the hub installing the firmware failed and nobody had controlled the result of the firmware installation.

with best regardrs
Hi Pezi,

I assumed the firmware had loaded, but it was NOT.

I think many people would appreciate your findings to solve the problem.



Who is online

In total there are 5 users online :: 0 registered, 0 hidden and 5 guests (based on users active over the past 5 minutes)
Most users ever online was 5185 on Wed Jan 22, 2020 1:44 pm

Users browsing this forum: No registered users and 5 guests