Power & Source of Big Ideas

NanoPi NEO very slow ethernet

Moderators: chensy, FATechsupport

Hello,
I bought a NanoPi NEO. I accidentally bought it without the ethernet socket. Because I need ethernet, I soldered a ethernet socket to myself. It is a different type than the one specified by friendlyarm in the schematic. But It has the same electrical and mechanical specifications. My equipment and my soldering skills are very good, so I think there should be no solder mistake.

Ethernet is now working with my NanoPi NEO. But its extremly slow. I have transfer rates of a few 100 KB/s. I think this should be higher.
So what can be the reason? Do I have to add further components to the board?
If it is working I would doubt extra parts can to be added to increase the speed. I have read discussions about Ethernet speeds on various boards, so I would focus on what an NEO that comes with that port is capable of.

I believe some SBC (single board computers) use the USB bus to handle the ethernet comms, is the NEO one of them?
On the NanoPi NEO the ethernet port ist directly connected to the Allwinner H3. So there should be no problem with USB.
So there should be no problem with USB.
Not too sure what this comment means.

If it did use a USB to ethernet bridge and specifically USB 2 then the ethernet speeds might be lower than a proper ethernet implementation. I would assume USB would not be affected in this case or if a proper ethernet implementation was used. That is just my understanding.

I would go looking for armbian or the AllWinner forums where you might find out what the limitations are on ethernet speeds.

Good luck!

Who is online

In total there are 2 users online :: 0 registered, 0 hidden and 2 guests (based on users active over the past 5 minutes)
Most users ever online was 47 on Wed Feb 21, 2018 7:00 am

Users browsing this forum: No registered users and 2 guests