Power & Source of Big Ideas

Run fsck at boot

Moderators: chensy, FATechsupport

Hi, I cannot seem to run fsck at boot, which is needed as my device will be in a battery environment. I have tried updating /boot/boot.cmd and generating a boot.scr containing both forcefsk and fcsk.mode=force, none of them works. I tried creating a file /forcefsck but no luck there either. Anyone know?
which board?
Sorry! NanoPI NEO, running Xenial 4.11. It also warns that fsck should be run at every boot

Code: Select all

Begin: Will now check root file system ... fsck from util-linux 2.27.1
[/sbin/fsck.ext4 (1) -- /dev/mmcblk0p2] fsck.ext4 -y -C0 /dev/mmcblk0p2
e2fsck 1.42.13 (17-May-2015)
rootfs: clean, 51987/115200 files, 295821/460800 blocks
Thanks, but did you not miss to include how to get that output you pasted?

Who is online

In total there are 12 users online :: 0 registered, 0 hidden and 12 guests (based on users active over the past 5 minutes)
Most users ever online was 5185 on Wed Jan 22, 2020 1:44 pm

Users browsing this forum: No registered users and 12 guests