Power & Source of Big Ideas

Nanopi neo air wont boot from emmc.

Moderators: chensy, FATechsupport

Hi!
Board from subject wont boot from emmc.
No any messages from debug UART.
From SD-Card boot normally, /dev/mmcblk1boot0 and /dev/mmcblk1boot1 is empty.

root@nanopiair:~# hexdump -C /dev/mmcblk1boot0
00000000 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 |................|
*
00400000
root@nanopiair:~# hexdump -C /dev/mmcblk1boot1
00000000 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 |................|
*
00400000

root@nanopiair:~# lsblk
NAME MAJ:MIN RM SIZE RO TYPE MOUNTPOINT
mmcblk1boot0 179:32 0 4M 0 disk
mmcblk1boot1 179:48 0 4M 1 disk
mmcblk0 179:0 0 14.9G 0 disk
└─mmcblk0p1 179:1 0 1.2G 0 part
mmcblk1 179:16 0 7.3G 0 disk
└─mmcblk1p1 179:17 0 7.1G 0 part /

Read/Write data to EMMC ok, without any problem.

Help me please.
That should contain /dev/mmcblk1boot0 and boot1, where download and how to write this partition?
You could try to dd a image of the sdcard to the emmc:

1.) boot from sd-card
2.) insert a USB-Stick with a .img file of the sdcard in the USB-Port
3.) mkdir /mnt/sda1
4.) mnt /dev/sda1 /mnt/sda1
5.) dd if=/mnt/sda1/[name_of_the_image].img of=/dev/mmcblk0 bs=1M && sync
6.) to be sure: sync [+ENTER-key) again :)
7.) shutdown -h now
8.) remove sdcard
9.) power on - should now boot via emmc

(done this on a odroid C2 - but should be the same with the right .img on your system :) )
Hi, thanks for your reply.
Unfortunately it did not help.
System boot only if SD-Card inserted. If write image to emmc (/dev/mmcblk1), system boots from emmc, if image write to USB drive, and emmc clean system boot from USB.
If SD-Card not present, board not init boot process, no any message on console, no LED lighting.

Who is online

In total there are 9 users online :: 0 registered, 0 hidden and 9 guests (based on users active over the past 5 minutes)
Most users ever online was 5185 on Wed Jan 22, 2020 1:44 pm

Users browsing this forum: No registered users and 9 guests