Power & Source of Big Ideas

Compiling kernel with 802.1Q module

Moderators: chensy, FATechsupport

Hi, I'm a newbie in compiling kernel images

I'm trying to compile the kernel for the NanoPi M3 with 8021Q enabled - but
I get the following error:
" CC drivers/net/ethernet/nexell/nxpmac/nxpmac_main.o
drivers/net/ethernet/nexell/nxpmac/nxpmac_main.c: In function
drivers/net/ethernet/nexell/nxpmac/nxpmac_main.c:3174:20: error:
‘NETIF_F_HW_VLAN_CTAG_RX’ undeclared (first use in this function)
ndev->features |= NETIF_F_HW_VLAN_CTAG_RX;
drivers/net/ethernet/nexell/nxpmac/nxpmac_main.c:3174:20: note: each
undeclared identifier is reported only once for each function it appears in
drivers/net/ethernet/nexell/nxpmac/nxpmac_main.c: At top level:
drivers/net/ethernet/nexell/nxpmac/nxpmac_main.c:967:13: warning:
‘stmmac_display_descriptors’ defined but not used [-Wunused-function]
static void stmmac_display_descriptors(struct stmmac_priv *priv)
make[5]: *** [drivers/net/ethernet/nexell/nxpmac/nxpmac_main.o] Error 1
make[4]: *** [drivers/net/ethernet/nexell/nxpmac] Error 2
make[3]: *** [drivers/net/ethernet/nexell] Error 2
make[2]: *** [drivers/net/ethernet] Error 2
make[1]: *** [drivers/net] Error 2
make: *** [drivers] Error 2

In the Old Forum, I've been told that it might be because there's a missing .h file, but I've not been able to determine which .h file is needed.

Could someone please help me?
Awesome! Thank you. It compiles...

Just a question, though: What would this patch break?

OK...So it was not as easy as that...Installed the uImage, and it booted up fine.

Then I tried to
modprobe 8021q
and of course it tells me it cannot find the module.

Riiightt...I have to compile the module. And this is where I got caught in a snag:
make CROSS_COMPILE=arm-linux- modules
This does not create the 8021q module
Then I tried going into ./net/8021q/ and run
make CROSS_COMPILE=arm-linux- 8021q and I get this error:
8021q.o: error adding symbols: File in wrong format

Can anybody perhaps help on this point?


An update: I changed the .config file to state
then I did
make CROSS-COMPILE=arm-linux- modules

I replaced my old uImage with the new one and I copied the file 8021q.ko that was created to /lib/modules/3.4.39-s5p6818/kernel/net/8021q

But when I do modprobe 8021q, it cannot find it.

And when I do insmod ./3.4.39-s5p6818/kernel/net/8021q/8021q.ko, it says Invalid module format.

Any suggestions?


a. The WIFI driver source code is in https://github.com/friendlyarm/wireless ,you can use build.sh to compile . If you use Android , the AP6212 is integrate in the kernel source code drivers/net/wireless/bcm4336/ . There are no differences.
b. You can get RSSI through linux interface ,such as netlink/wireless extention, you need to read the materials to get detailed ways.
c.The WiFi under the Debian/Ubuntu Core system doesnot use the kernel comes with, the source code and the build scripts is in https://github.com/friendlyarm/wireless

thank you!

Who is online

In total there is 1 user online :: 0 registered, 0 hidden and 1 guest (based on users active over the past 5 minutes)
Most users ever online was 5185 on Wed Jan 22, 2020 1:44 pm

Users browsing this forum: No registered users and 1 guest