Power & Source of Big Ideas

CAM500 & Fire3 : ion issue

Moderators: chensy, FATechsupport

I've tried the nanocams program provided with the armhf release of friendlycore, namely s5p6818-friendly-core-xenial-4.4-armhf-20171212.img ... and here is the output of the program :

Code: Select all

Memory usage:  5 % of 953Mb     IP:  
CPU temp:      46°C
Usage of /:    5% of 29G

 * Documentation: http://wiki.friendlyarm.com/Ubuntu
 * Forum: http://www.friendlyarm.com/Forum/

To run Qt5 demo, type "qt5demo" at the command prompt and then hit the enter key.
To play a video demo, use command "sudo gst-player /home/pi/demo.mp4".
Last login: Thu Jan 25 23:34:55 2018 from
pi@fire3:~$ sudo nanocams -p 1 -n 40 -c 4 -o IMG001.jpg
open /dev/ion failed!
E/542: failed to ion_open, errno = 2

I tried twice to format/reload the image, but each time I boot the device, I can see some kernel modules failing :

Code: Select all

[ OK ] Started Remount Root and Kernel File Systems.
[    4.932000] systemd[1]: systemd-modules-load.service: Main process exited, code=exited, status=1/FAILURE
[    4.936000] systemd[1]: Failed to start Load Kernel Modules.
[  FAILED  ] Failed to start Load Kernel Modules.
See 'systemctl status systemd-modules-load.service' for details.
[    4.972000] systemd[1]: systemd-modules-load.service: Unit entered failed state.
[    4.972000] systemd[1]: systemd-modules-load.service: Failed with result 'exit-code'.
[    4.980000] systemd[1]: Started Set console keymap.
[  OK  ] Started Set console keymap.

The advises systemctl command issues these infos :

Code: Select all

pi@NanoPi-Fire3:~$ systemctl status systemd-modules-load.service
● systemd-modules-load.service - Load Kernel Modules
   Loaded: loaded (/lib/systemd/system/systemd-modules-load.service; static; ven
   Active: failed (Result: exit-code) since Sat 2018-01-27 03:06:12 UTC; 4min 10
     Docs: man:systemd-modules-load.service(8)
  Process: 268 ExecStart=/lib/systemd/systemd-modules-load (code=exited, status=
 Main PID: 268 (code=exited, status=1/FAILURE)

This #268 boot process is logged as such :

Code: Select all

pi@NanoPi-Fire3:~$ sudo journalctl -b _PID=268
-- Logs begin at Sat 2018-01-27 03:06:11 UTC, end at Sat 2018-01-27 03:16:08 UTC
Jan 27 03:06:12 NanoPi-Fire3 systemd-modules-load[268]: Module 'hci_uart' is bui
Jan 27 03:06:12 NanoPi-Fire3 systemd-modules-load[268]: Module 'bnep' is builtin
Jan 27 03:06:12 NanoPi-Fire3 systemd-modules-load[268]: Failed to find module 'v
Jan 27 03:06:12 NanoPi-Fire3 systemd-modules-load[268]: Failed to find module 'n

What are those 'v' and 'n' modules, I have no clue... Are they related to ion ? :?

Did someone actually manage to have the nanocamps util running, and if so, under which Fire3 image ? :cry:
And by the way, why are the /dev/ion dependencies missing on the OS image ?

Who is online

In total there are 5 users online :: 0 registered, 0 hidden and 5 guests (based on users active over the past 5 minutes)
Most users ever online was 5185 on Wed Jan 22, 2020 1:44 pm

Users browsing this forum: No registered users and 5 guests