Power & Source of Big Ideas

WARN err-22 Bootup to Linux

Moderators: chensy, FATechsupport

Hi,
When I bootup to linux, seeing the err -22 ? what the happend?

Code: Select all

[    1.888000] nxp-rtc nxp-rtc.0: rtc core: registered nxp-rtc as rtc0
[    1.892000] i2c /dev entries driver
[    1.900000] lirc_dev: IR Remote Control driver registered, major 248
[    1.904000] IR NEC protocol handler initialized
[    1.908000] usb 1-1.2: New USB device found, idVendor=046d, idProduct=082d
[    1.908000] usb 1-1.2: New USB device strings: Mfr=0, Product=2, SerialNumber=1
[    1.908000] usb 1-1.2: Product: HD Pro Webcam C920
[    1.908000] usb 1-1.2: SerialNumber: 426EA4AF
[    1.932000] IR RC5(x) protocol handler initialized
[    1.940000] IR RC6 protocol handler initialized
[    1.940000] WARN::ep_queue:343: bogus device state
[    1.940000]
[    1.940000] WARN::ep0_do_stall:1336: req 80.06 protocol STALL; err -22
[    1.940000]
[    1.940000] WARN::ep_queue:343: bogus device state
[    1.940000]
[    1.940000] WARN::ep0_do_stall:1336: req 80.06 protocol STALL; err -22
[    1.940000]
[    1.940000] WARN::ep_queue:343: bogus device state
[    1.940000]
[    1.940000] WARN::ep0_do_stall:1336: req 80.06 protocol STALL; err -22
[    1.940000]
[    1.944000] USB RESET
[    2.012000] IR JVC protocol handler initialized
[    2.016000] IR Sony protocol handler initialized
[    2.020000] IR RC5 (streamzap) protocol handler initialized
[    2.024000] IR SANYO protocol handler initialized
[    2.028000] IR LIRC bridge handler initialized
[    2.036000] gspca_main: v2.14.0 registered
[    2.044000] ...................................ov5640_probe 2234
[    2.048000] ...................................ov5640_video_probe 2193
[    2.056000] ov5640 0-003c: reg_read: i2c read error, reg: 300a
[    2.060000] OV5640 read error!!!!!!!!!!!!!!!
[    2.064000] ov5640_initialize_ctrls.............1794...........
[    2.072000] uvcvideo: Found UVC 1.00 device HD Pro Webcam C920 (046d:082d)
[    2.080000] input: HD Pro Webcam C920 as /devices/platform/nxp-ehci/usb1/1-1/1-1.2/1-1.2:1.0/input/input2
[    2.088000] usbcore: registered new interface driver uvcvideo
[    2.096000] USB Video Class driver (1.1.1)


--Regards,
HuyLe
reboot again system boot again.. can't login to root.
The log show the many many

Code: Select all

[    1.632000] usb usb3: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[    1.640000] usb usb3: Product: SLsi Synopsys OHCI Host Controller
[    1.640000] WARN::dwc_otg_pcd_handle_noniso_bna:3175: Ep0 OUT Descriptor count = 0
[    1.640000]
[    1.640000] WARN::dwc_otg_pcd_handle_noniso_bna:3175: Ep0 OUT Descriptor count = 0
[    1.640000]
5: Ep0 OUT Descriptor count = 0
<4>[    1.640000]
<4>[    1.640000] WARN::dwc_otg_pcd_handle_noniso_bna:3175: Ep0 OUT Descriptor count = 0
[    1.640000]
[    1.640000] WARN::dwc_otg_pcd_handle_noniso_bna:3175: Ep0 OUT Descriptor count = 0
ndle_noniso_bna:3175: Ep0 OUT Descriptor count = 0
[    1.640000]
[    1.640000] WARN::dwc_otg_pcd_handle_noniso_bna:3175: Ep0 OUT Descriptor count = 0
[    1.640000]
5: Ep0 OUT Descriptor count = 0
<4>[    1.640000]
<4>[    1.640000] WARN::dwc_otg_pcd_handle_noniso_bna:3175: Ep0 OUT Descriptor count = 0
[    1.640000]
[    1.640000] WARN::dwc_otg_pcd_handle_noniso_bna:3175: Ep0 OUT Descriptor count = 0
[    1.640000]
5: Ep0 OUT Descriptor count = 0
<4>[    1.640000]
<4>[    1.640000] WARN::dwc_otg_pcd_handle_noniso_bna:3175: Ep0 OUT Descriptor count = 0
[    1.640000]
[    1.640000] WARN::dwc_otg_pcd_handle_noniso_bna:3175: Ep0 OUT Descriptor count = 0
ndle_noniso_bna:3175: Ep0 OUT Descriptor count = 0
[    1.640000]
[    1.640000] WARN::dwc_otg_pcd_handle_noniso_bna:3175: Ep0 OUT Descriptor count = 0
ndle_noniso_bna:3175: Ep0 OUT Descriptor count = 0
[    1.640000]
[    1.640000] WARN::dwc_otg_pcd_handle_noniso_bna:3175: Ep0 OUT Descriptor count = 0
[    1.640000]
5: Ep0 OUT Descriptor count = 0
<4>[    1.640000]
<4>[    1.640000] WARN::dwc_otg_pcd_handle_noniso_bna:3175: Ep0 OUT Descriptor count = 0
[    1.640000]
[    1.640000] WARN::dwc_otg_pcd_handle_noniso_bna:3175: Ep0 OUT Descriptor count = 0
ndle_noniso_bna:3175: Ep0 OUT Descriptor count = 0
[    1.640000]
[    1.640000] WARN::dwc_otg_pcd_handle_noniso_bna:3175: Ep0 OUT Descriptor count = 0
ndle_noniso_bna:3175: Ep0 OUT Descriptor count = 0
[    1.640000]
[    1.640000] WARN::dwc_otg_pcd_handle_noniso_bna:3175: Ep0 OUT Descriptor count = 0
ndle_noniso_bna:3175: Ep0 OUT Descriptor count = 0
[    1.640000]
[    1.640000] WARN::dwc_otg_pcd_handle_noniso_bna:3175: Ep0 OUT Descriptor count = 0
ndle_noniso_bna:3175: Ep0 OUT Descriptor count = 0


--Regards,
HuyLe
The new Image of 17 April 2017 release seeing this issue when I hot-plug USB. :).

-- Regards,
HuyLe
Are you getting this error if you have the USB device plugged in BEFORE you boot up?

Or do you only get this error when you try to hot-plug the USB device, ie after booting?

I suspect you get errors trying to do either task.
Which use case do you need to do?

If it is hotplugging you want then have a look at this:
http://www.makeuseof.com/tag/how-to-mount-a-usb-flash-device-in-linux-and-your-raspberry-pi/
Hi Davef,

I receive error when USB device plugged in uboot, bootup success, then unplug USB.
Only 3 times I saw the error. Currently don't seeing error. If see, will to reporting next.

Regards,
HuyLe

Who is online

In total there are 2 users online :: 0 registered, 0 hidden and 2 guests (based on users active over the past 5 minutes)
Most users ever online was 42 on 15 Jul 2016, 01:04

Users browsing this forum: No registered users and 2 guests