Power & Source of Big Ideas

Debian Jessie Hints

Moderators: chensy, FATechsupport

After a few hours trying to understand a variety of errors I did the following:

apt-get upgrade
apt-get dist-upgrade
apt get autoremove

and then downloading packages behaved as expected. Perhaps the above is "standard-procedure" after installing a new Linux OS, but maybe worth mentioning again.
Hi davef

Thank you for your input. We updated our wiki by adding this command set.
Wanted to disable Bluetooth so found this modification:

in /etc/rc.local

add this line:

rfkill block bluetooth

before the line:

exit 0
Invoking the command:

find -name xyz -print

does not appear to work the first time, so just repeat the command
Bootargs and what happens if you make a mistake


Connect TFT LCD (section) on the NanoPi Wiki page

fw_printenv bootargs

Append "lcd=S70" to "bootargs=" and reset the list with "fw_setenv"

Suggest that line is changed to:

Append "lcd=S70" as shown below and save the environment.

fw_setenv bootargs root=/dev/mmcblk0p2 rootfstype=ext4 init=/sbin/init console=ttySAC0,115200 lcd=S70

Do not “copy and paste” the bootargs= line in your terminal program thinking that you will just modify it … at least with minicom the line was executed immediately, which then resulted in a kernel panic on the next boot :( Also, double-check your intended modification to ensure you have got it correct!

If you mess this up, reboot the NanoPi and within 3 seconds stop the boot process and do a printenv, in your terminal window, to see where you went wrong.

Then try:

setenv bootargs root=/dev/mmcblk0p2 rootfstype=ext4 init=/sbin/init console=ttySAC0,115200 lcd=S70

or whatever your intended modification is.
Is your system really slow reading the packages list?

A procedure is explained at http://antti-juhani.kaijanaho.fi/newblog/archives/521

I just did:
dpkg --clear-avail

(Evidently, dpkg --forget-old-unavail is not required)

Downloaded the dctrl-tools package and ran
sync-available

What a difference!
Hi all,
I own a nanopi and I intend to use in a standalone environment where it is powered by a battery pack. In order to save power consumption I want to put the device in standby mode and once an hour it needs to wake up. It should do than some measurements, save it to SD and go again to enjoy some sleeping time. However, rtcwake does not seem to be supported. The utility is available but not working:
rtcwake -m standby -s 60
===> says rtcwake: suspend to "standby" unavailable
rtcwake -m mem -s 60 says
===>rtcwake: wakeup from "mem" using /dev/rtc0 at Thu Jan 1 12:56:40 2015
rtcwake: write error.

Any help from you guys. Is there a different approach I should be using to achieve my goal?
Thanks in advance.
Hi Sorry this function might not be supported in NanoPi. In order for this function to be supported uboot, kernel and hardware all need to be configured and setup. The hardware doesn't support this function and we didn't specifically test the uboot and kernel for this function either.
Isn't one of the problems the lack of an RTC? Assuming you want to run Linux what about the NanoPi2 Fire. It has a PMU,maybe you will need an external RTC unit.

I am running the NanoPi in a power-constrained application because it has much lower current consumption than the mini2440. However, no match for a microcontroller with sleep modes!
I have had a few hours to think about this.

When I first started looking at the NanoPi I recall that there was a RTC timer. However, being used to externally battery-backup RTCs I came to the conclusion, perhaps incorrectly, was how was running this off the main 5V supply and without a PMU going to reduce current consumption.

Also, I would like to change my NanoPi2 Fire statement to "maybe an external RTC is NOT required".

Are you looking for orders of magnitude less current consumption?
Thanks guys for your replies. Basically I want to reduce the power consumption to the minimum and I want to use whatever option to get there.
Do you have any suggestion to achieve this goal?

Is it possible to switch off the WiFi power? That would help a lot I guess.

Thanks
Do you need to run Linux in your application?

I turn off Bluetooth by adding this to /etc/rc.local

rfkill block bluetooth

I would try:

rfkill block wifi

and see what happens. Haven't wanted to do that ... yet.
davef,
you're a star. Thanks a lot. you pushed me in the right direction.
I was able to switch off the WiFi and I would expect power consumption will dramatically decrease.
I will do some testing to figure out what the power consumption is in both scenarios (with and without WiFi).
Thanks again
Any results re turning off WiFi?

Had a look through the datasheet for a way of turning down the WiFi power level, My NanoPi is about 1 metre away from my Smartphone/hotspot.

Is there a register description or API or some command for doing this?

Thanks,
Dave
Hi davef,
I followed your instructions as I was able to switch off the WiFi.
I then did some dirty measurements trying to figure out what the power consumption is. This what I did:
I created a small python script that writes the current time to a file on the SD card, each 5 minutes. I used a power bank of 2200 mAh and 5V (fully charged) to power the nanopi. After a while the battery runs out and the nanopi stops working:
- Having WiFi on, nanopi needed 7:15 h to drain out the power bank.
- Switching off the Wifi same power bank took 11 h to drain out.

So switching off the WiFi has resulted in a better improvement, but still I would like to bring the power consumption down as the nanopi will only need to take some measurements store them om SD and go back to sleep for another hour.

davef,
You asked lately if I have to use Linux. Is there any other OS i can use to save more power?
Thanks
It would be much quicker to stuff a ammeter in series with the battery to determine current consumption. However, you found a work-around!

Maybe you don't need an operating system. I run FatFS on a ATmega32 /ATmega88, as a datalogger. There are P versions of the 88, I think and they have various sleep modes in them.

Maybe describe your system in a bit more detail and I'll try to make some useful comments. Send a PM as this is becoming off-topic.
To install Webmin have to download it then do:

tar xzvf webmin-1.801.tar.gz
cd webmin-1.801/
./setup.sh

It works like that.

Got a lot of "Unable to locate package" But can just find them and wget and install them like phpsysinfo

It's nice for how small it is. Runs good and putty fast.

-Raymond Day

Who is online

In total there are 2 users online :: 0 registered, 0 hidden and 2 guests (based on users active over the past 5 minutes)
Most users ever online was 47 on Wed Feb 21, 2018 7:00 am

Users browsing this forum: No registered users and 2 guests